О проекте WIDI
Основная задача программы WIDI это распознавание музыки. Музыкальная запись может быть представлена в двух различных формах: звуковая волна и нотная запись. Звуковая волна - это запись зависимости звукового давления от времени. Примерами могут служить файлы формата .wav и .mp3, магнитофонные записи и так далее. В таком виде, проигрываемый звук в точности совпадает с тем, который был записан. Тем не менее, в этом случае, многие инструменты и звуки, которые звучат одновременно, перекрываются. Это делает невозможным внесение в музыкальное произведение таких изменений как изменение нот, аранжировки и т.д. Нотная запись - например, обычная партитура или файл формата MIDI, по сути являются набором команд, какую ноту каким инструментом следует сыграть. Такая форма записи легко поддается редактированию и занимает меньше места, чем файлы .wav. Однако, не любой звук может быть записан в такой форме. Например, человеческую речь записать в виде нотной записи невозможно.

Задача распознавания, в особенности распознавания музыкальных записей, является серьезной математической проблемой, и не имеет в настоящее время универсального решения. Тем не менее, WIDI Recognition System включает в себя алгоритмы, которые позволяют осуществлять распознавание полифонических записей с достаточно высокой точностью. Более того, значительное число настраиваемых параметров позволяют распознавать различные музыкальные стили, инструменты и так далее.

WIDI является уникальной многофункциональной системой, включающей в себя функции записи и отображения звуковой волны, специализированный редактор нот (только версия Professional), который позволяет осуществлять визуальное сравнение спектрограммы исходной волны и нот, полученных в процессе распознавания.

WIDI умеет читать исходные файлы в таких форматах, как некомпрессированный wav, mp3, CD треки и даже звук, непосредственно поступающий с микрофона, без предварительной записи в файл (распознавание в реальном времени).

WIDI позволяет, имея только звуковую волну, распознать ее и после этого:

· Изменять аранжировку, высотный диапазон и тональность
· Создавать предварительный просмотр для файлов mp3 в коллекциях
· Загружать любимые мелодии в мобильный телефон
· Получать нотные записи музыкальных композиций для самостоятельного исполнения

(Для редактирования нот и загрузки мелодий в мобильный телефон вам может понадобится стороннее программное обеспечение)


Новости
WIDI 3.2:

· Создан новый интерфейс с широкими возможностями настройки.
· Добавлен Мастер распознавания, позволяющий получить первые результаты уже через пару минут после первого запуска и одновременно ознакомиться с программой.
· Теперь WIDI умеет работать со стерео записями - отображать их в окне Аудио, а также распознавать каналы по-отдельности и в различных комбинациях.
· Окно MIDI теперь позволяет транспонировать MIDI-файлы и изменять используемый инструмент.
· Создана новая версия редактора TrueTone (только WIDI Professional):
· Появилась функция множественного выделения, работы с буфером, увеличено количество режимов проигрывания, добавлена операция "Повторить".
· Добавлены новые инструменты в редакторе - Карта нот, а также Редактор треков, позволяющий работать с треками по-отдельности и отображать их разными цветами.
· Добавлена возможность разделения на такты в MIDI. Расстановка тактовых черт может быть произведена как на слух, с помошью инструмента Теппинг, так и в ручном режиме. Вы можете создавать MIDI файлы с правильной расстановкой тактовых черт, что значительно улучшает читаемость нот.
· Теперь поддерживаются файлы установок в диалоге Параметры распознавания и других диалогах. Вы можете подобрать наиболее подходящий вариант установок алгоритмов для каждого случая, а также сохранить свои собственные удачные установки.
· Исправлена ошибка, возникающая при чтении Аудио CD на некоторых системах.
· Теперь ознакомительная версия программы позволяет сохранять в файл до 10 секунд MIDI.

WIDI 3.0:

· Теперь мы выпускаем новую версию программы в двух вариантах: WIDI Recognition System Standard and WIDI Recognition System Professional. Основное отличие заключается в наличии специализированного редактора TrueTone (tm), включенного в WIDI Professional.
· Добавлен модуль распознавания в реальном времени (программа позволяет определять ноты, исполняемые на любом инструменте на лету и синхронно проигрывать их, а также сохранять в файл MIDI).
· Разработан новый редактор TrueTone (tm) (только в версии Professional). Этот редактор специально создан, чтобы упростить исправление возможных ошибок возникающих в процессе автоматического распознавания.
· В интерфейс программы внесены изменения, делающие его более удобным.
· Добавлены новые алгоритмы.
· Исправлены некоторые ошибки.
· Прекращена поддержка версий для DOS, консольной и OS/2.

WIDI 2.7:

· Добавлен новый алгоритм, названный "Улучшенные Сенсоры". Алгоритм включает в себя возможность автоподстройки, что позволяет значительно снизить количество не гармонических нот. Здесь можно прочесть о нем более подробно.
· Добавлена поддержка ACM (Audio Compression Manager), теперь программа позволяет открывать любой тип аудио-файлов, для которых установлен ACM кодек. ADPCM, A-Law, u-Law и многие другие кодеки как-правило установлены по умолчанию. Более подробная информация содержится в разделе Поддерживаемые форматы.
· Добавлена поддержка чтения напрямую с аудио-CD дисков. Теперь можно просто открывать файлы *.cda с Вашего CD-ROM. Более подробная информация содержится в разделе Поддерживаемые форматы.
· Вы можете сохранять копии аудио-треков и сжатых файлов во временные файлы, значительно повышая скорость повторных попыток распознавания. Для более детальной информации прочтите раздел Настройки.
· Теперь возможно записывать звуковые файлы непосредственно в WIDI. Подробности - в разделе Запись звука.
· Исправлена ошибка в реализации метода "Peak", что значительно повысило его эффективность.


Возможности
Основная задача программы WIDI это преобразование оцифрованных музыкальных полифонических записей в файлы MIDI и распознавание музыки в реальном времени.

Исходные данные
Полифонические и монофонические записи в форматах MP3, WAVE, и аудио CD-треки.
Звук поступающий с микрофона в реальном времени.
Поддерживаются также сжатые файлы WAVE.
Некоторые другие форматы (AIFF/AIFF-C, NeXT/Sun .snd/.au, Berkeley/IRCAM/CARL Sound File) поддерживаются с помощью библиотеки Audio File.

Основные особенности распознавания
Возможность выбрать один из нескольких алгоритмов, в том числе специально предназначенных для монофонического распознавания.
Алгоритм распознавания автоматически подстраивается под тональность произведения.
Простая гармоническая модель позволяет автоматически исключать ошибочные ноты.
Многочисленные настройки распознавания позволят достигнуть наивысшего качества распознавания.
Установки распознавания могут быть сохранены в файл для повторного использования.
Созданы наборы установок распознавания для некоторых типичных случаев.
Существует возможность выбрать частотный диапазон в котором будет производится распознавание.
Возможность распознавания отдельных каналов стерео-записи и их комбинаций.

Возможности редактирования
Возможно выделить для распознавания любую часть музыкальной записи.
Использование редактора TrueTone (tm), включенного в версию Professional, позволяет эффективно повысить качество распознавания. Редактор позволяет значительно улучшить читаемость нотной записи, благодаря возможности расставлять тактовые черты, не изменяя звучания.

Работа в реальном времени
Вы можете распознавать ноты "на лету", управляя MIDI-синтезатором непосредственно из модуля распознавания в реальном времени.

Представление результата
На выходе получается многоканальный, отсортированный по громкости файл MIDI.
Есть возможность выбрать один из большего списка инструментов, чтобы использовать его в результирующем файле MIDI.

Дополнительные возможности
Возможно записывать звук с микрофона или с любого другого входа, используя встроенный звукозаписывающий модуль.
Встроенный эквалайзер позволяет настраивать относительную громкость нот различной высоты.
Возможно проиграть файлы всех поддерживаемых форматов.


Системные требования
Для работы с WIDI 3.2 Standard или Professional требуется конфигурация:

Процессор | Pentium II (рекомендуется 450 MHz)
Оперативная память | 32 Мб или больше
Место на диске | 5 Мб + место для временных файлов (рекомендуется не менее 100 Мб)
Операционная система | Win98/ME, Windows NT/2000/XP
Звуковая карта | Рекомендуется

Замечание: Работоспособность WIDI под Windows 95 не гарантируется.


Установка/Удаление
Установка

Если предыдущая версия WIDI была установлена, рекомендуется ее предварительно удалить. Для установки WIDI, запустите файл widi32inr.exe пользуясь меню Start->Run или дважды кликнув по нему мышкой, после чего следуйте указаниям программы установки.

Если Вы зарегистрировали WIDI, в разделе Введение регистрационного кода содержится инструкция, как зарегистрировать вашу копию программы.

Удаление

Чтобы удалить WIDI, пользуйтесь стандартной процедурой Windows (Control Panel ->Add/Remove Programs->WIDI Recognition System 3.2) или выберите WIDI->Uninstall WIDI Recognition System 3.2 и следуйте инструкциям программы удаления.


Мастер Распознавания
По умолчанию при запуске WIDI в первую очередь запускается Мастер распознавания. Используя Мастер распознавания вы можете получить первые результаты распознавания уже через пару минут, и заодно познакомится с программой. Заглавная страница мастера выглядит следующим образом:

Распознать уже существующий mp3, Wave или CD - дает возможность указать для распознавания mp3, Wave файл или CD-трек.
Записать аудио и распознать его - дает возможность записать аудио используя встроенный звукозаписывающий модуль и распознать его.
Распознавание в реальном времени - включает модуль распознавания в реальном времени.
Показать страницу быстрого старта - открывает файл помощи на странице Быстрый старт.
Закрыть Мастер распознавания - закрывает мастер распознавания.

Показывать Мастер при старте программы - если этот флажок поставлен, то при старте программы в первую очередь запустится Мастер распознавания.

Выберете интересующий вас пункт и нажмите кнопку Далее.

Распознавание уже существующего аудио-файла

· Воспользовавшись кнопкой Поиск укажите местоположение искомого фала, после чего нажмите Далее.
· Используя кнопку Параметры, установите параметры распознавания вручную, либо выберите из списка одну из существующих предустановок. Кнопка Импорт позволит указать любой файл установок распознавания.
· После этого Мастер предлагает открыть результат распознавания в редакторе TrueTone (только WIDI Professional).

Запись аудио и распознавание

· Кнопка Далее запускает модуль записи звука.
· Используя кнопку Параметры, установите параметры распознавания вручную, либо выберите из списка одну из существующих предустановок. Кнопка Импорт позволит указать любой файл установок распознавания.
· После этого Мастер предлагает открыть результат распознавания в редакторе TrueTone (только WIDI Professional).

Распознавание в реальном времени

· Кнопка Далее запускает модуль распознавания в реальном времени.


Быстрый старт
Несколько простых операций можно проделать, для начала, не углубляясь в изучение WIDI.

При первом знакомстве с программой, рекомендуется воспользоваться Мастером распознавания.

Распознавание предварительно записанных файлов
· Выберите требуемый файл (Нажмите [image] Открыть).
· Нажмите [image] Распознать и дождитесь, пока процесс распознавания завершится.
· Теперь результат распознавания можно прослушать (нажмите [image] Проиграть).
· Если Вы используете зарегистрированную версию, сохраните файл (нажмите [image] Сохранить).

Распознавание в реальном времени
· Запустите модуль распознавания в реальном времени (нажмите [image] В реальном времени).
· Пойте или играйте на музыкальном инструменте в микрофон.
· Запустите Микшер Windows (нажмите [image] Микшер Windows).
· Установите источник звука и уровень записи. Указатель уровня при этом отражает поступающий сигнал. При необходимости, обратитесь к документации Windows.
· Ноты MIDI должны звучать сразу как только вы их поете или играете.
· Запустите запись нажав кнопку [image] Запись.
· Записанный материал становится доступным после нажатия кнопки Готово.
· Теперь вы можете прослушать результат (нажмите кнопку [image] Проиграть на окне MIDI).
· Сохраните файл (нажмите [image] Сохранить). Ознакомительная версия программы позволяет сохранять в файл до 10 секунд MIDI.

Используя версию Professional вы можете также редактировать результат распознавания с помощью редактора TrueTone (tm).

Чтобы улучшить качество распознавания и воспользоваться другими функциями WIDI обратитесь к следующим разделам:
Использование WIDI
Дополнительные темы


Использование WIDI
Страницы этого раздела описывают основные операции, которые можно проделать, используя WIDI.


Запись звука
WIDI включает в себя простой звукозаписывающий модуль. Это позволяет записывать звук с микрофона или другого источника звука.

Модуль звукозаписи позволяет:

· Сохранять несжатые аудиофайлы произвольной длины.
· Записывать звук как в моно, так и в стерео режиме.
· Выбирать частоту дискретизации 11025, 22050 или 44100 Гц.
· Устанавливать разрешение 8 или 16 бит.
· Отслеживать уровень звука в процессе записи.
· Запись может производится с любого входного устройства (в пункте Установка устройства рассказано как их изментять).

Вы можете производить запись как во временный файл, так и в выбранный вами окончательный файл, более подробная информация есть в разделе Установки временного файла.

Если вы собираетесь использовать записанный файл только в текущей версии WIDI, Вам нет необходимости устанавливать качество записи выше чем 16 бит стерео 22050 Гц.

Чтобы запустить модуль звукозаписи, нажмите кнопку [image] Запись Звука на основной панели инструментов. Описание использования модуля можно прочитать в разделе Окно звукозаписи.


Распознавание записей
Распознавание записей - это распознавание предварительно записанных аудиофайлов. Если Вам необходимо сначало записать такой файл, в разделе Запись Звука можно прочитать, как это сделать.

Распознавание записей включает в себя следующие шаги:
· Загрузите требуемый исходный файл в WIDI (нажмите [image] Открыть).
· Выделите часть файла, которую Вы хотите распознать (по умолчанию выделен весь файл). Подробнее см. Окно Аудио.
· Запустите распознавание (нажмите [image] Распознать на Окне Аудио).
· Подождите завершения процесса.
· Прослушайте результат (подробнее см Проигрыватель MIDI).
· Варьируйте Установки Распознавания и положение Эквалайзера для достижения лучшего результата.
· Повторите предыдущий шаг до тех пор, пока вы не добьетесь приемлемого результата или не станет понятно что произведение слишком сложное для текущей версии WIDI.
· Вызовите редактор TrueTone(tm) из Проигрывателя MIDI если Вы пользуетесь версией Professional и исправьте все возможные ошибки ориентируясь на подложенную спектрограмму.
· Сохраните результат распознавания в MIDI файл, если вы зарегистрировали Вашу копию WIDI.

Распознавание записей как правило приводит к более высокому качеству распознавания чем распознавание в реальном времени. Имеется много параметров, влияющих на качество распознавания, и обычно требуется несколько раз подстроить их чтобы достигнуть приемлемой точности распознавания. WIDI позволяет сохранять настройки в файл для дальнейшей доработки или повторного использования.

Процесс распознавания требует большего количества вычислений. Он сильно загружает процессор и может занять много времени на медленных системах. Вы можете приостановить распознавание (и освободить процессор) или отменить его нажатием соответствующих кнопок. Вы можете ускорить повторное распознавание, используя файлы GS.


Распознавание в реальном времени
Распознавание в реальном времени позволяет производить запись как с микрофона так и с любого другого входа, указанного в качестве устройства ввода аудио и одновременно осуществлять преобразование звука в формат MIDI в соответствии с текущими установками.

Качество распознавания в реальном времени обычно ниже чем при распознавании предварительно записанного звука. Все ноты проигрываемые ноты имеют одинаковую громкость (так как громкость ноты не может быть определена до окончания ее звучания) и как правило более высоким оказывается число ошибок.

Распознавание в реальном времени состоит из следующих шагов:
· Запустите модуль распознавания в реальном времени (нажмите [image] В реальном времени).
· Пойте или играйте на музыкальном инструменте в микрофон.
· Запустите Микшер Windows (нажмите [image] Микшер Windows).
· Установите источник звука и уровень записи. Указатель уровня при этом отражает поступающий сигнал. При необходимости, обратитесь к документации Windows.
· Ноты MIDI должны звучать в тот момент когда вы их поете или играете.
· Варьируйте Установки Распознавания в реальном времени и настройки Эквалайзера для достижения лучшего результата. Изменения вступают в силу немедленно.

Если Вам требуется сохранить распознанные ноты:
· Запустите запись нажав кнопку [image] Запись MIDI.
· Записанный материал становится доступным после нажатия кнопки Готово. Если Проигрыватель MIDI не появился, значит не было записано ни одной ноты.
· Сохраните файл (нажмите [image] Сохранить). Ознакомительная версия программы позволяет сохранять в файл до 10 секунд MIDI.

Записанные ноты отличаются от тех которые были слышны в процессе. Перед сохранением записи вычисляются громкости нот и используется настройка "Минимальная Длина Ноты".


Редактор TrueTone(tm)
Редактор TrueTone(tm) это специализированный редактор MIDI, включенный в WIDI Professional.
Вы можете прочитать детальное описание редактора TrueTone.


Другие операции
Вы можете также использовать WIDI для выполнения других задач, не обязательно связанных с распознаванием музыки.

Проигрывание музыкальных файлов
Вы можете проигрывать различные музыкальные файлы с помошью WIDI. Используя кнопку [image] Открыть откройте нужный файл и проиграйте его с помощью кнопки [image] Проиграть. Вы можете проигрывать файлы Wave, MP3, MIDI и даже аудио CD-треки.

Синхронное проигрывание звуковой волны и файлов MIDI

Вы можете проигрывать аудиофайлы (Wave или MP3) совместно с файлом MIDI. Откройте звуковой файл и файл MIDI с помощью кнопки [image] Открыть и запустите синхронное проигрывание нажатием кнопки [image] Синхронное Проигрывание.

Редактирование любых файлов MIDI с помощью редактора TrueTone(tm)

Вы можете редактировать любые файлы MIDI используя редактор TrueTone(tm). Вы можете использовать его как клавишный редактор MIDI, но спектр будет недоступен, редактор будет работать в режиме "Только MIDI". Откройте файл MIDI нажатием кнопки [image] Открыть и запустите редактор TrueTone(tm) с помощью кнопки [image] Редактор TrueTone. Детальная информация в разделе Редактор TrueTone.


Установка Опций
Имеются настройки, влияющие на работу WIDI Recognition System в целом, в не зависимости от конкретных установок алгоритма распознавания. Здесь объяснены основные принципы работы с Основными Опциями.
Диалог Основных Опций вызвается нажатием кнопки [image] Основные Опции.

Временные файлы

WIDI использует временные файлы для сохранения аудио данных в несжатой форме. Обычно это делается в следующих случаях:
· Для новых временных записанных файлов.
· Для ускорение доступа при работе с компрессированными файлами (MP3, сжатый WAVE).
· Для доступа к данным на аудио-дисках.
В двух последних случаях, использование временных файлов очень сильно ускоряет скорость доступа.
Временные файлы могут потребовать очень много места на диске, поэтому выбирайте директорию для них с осторожностью. По умолчанию, временные файлы помещаются в ту же директорию что и сама программа. Если у Вас недостаточно места на диске, Вы можете запретить использование временных файлов, но это не рекомендуется, особенно при работе с аудио дисками.

Установки устройств ввода/вывода

Устройство ввода аудио используется для заведения звуковой информации в компьютер. И Распознавание в реальном времени и Запись звука используют это устройство. Как правило в системе имеются несколько Устройств ввода аудио, даже при наличии только одной звуковой карты. Каждое Устройство ввода аудио может получать аудио-данные от нескольких источников звука или каналов (микрофон, линейный вход, и.т.д), но как правило только от одного одновременно. Если Вам не удается ничего записать, возможно Вы выбрали не то Устройство ввода аудио или неправильно указали источник звука для него. Вы можете выбрать Устройство ввода аудио в Закладке "Устройства" диалога Опции, но выбрать источник звука можно только при помощи Микшера Windows (Свойства Записи), для более подробной информации обратитесь к его документации.

Устройство вывода аудио используется для вывода звука из компьютера. Проигрывая MP3, WAVE или аудио-CD (в WIDI) Вы используете Устройство вывода аудио. Обычно много источников могут выводить звук через одно и то же Устройство вывода аудио. Если Вы ничего не слышите при проигрывании каких-либо MP3 или WAVE файлов, это может означать, что какие-то каналы заглушены или на них выставлен слишком низкий уровень в Микшере Windows, или Вы указали неверное Устройство вывода аудио в WIDI.

Устройство вывода MIDI используется для проигрывания MIDI-команд (нот и некоторых специальных команд). И встроенные, и внешние синтезаторы MIDI являются Устройствами вывода MIDI. Чтобы добиться правильного проигрывания MIDI на встроенном MIDI-синтезаторе, Вам необходимо указать его в качестве Устройства вывода MIDI в WIDI и установить его громкость в Микшере Windows. Для того, чтобы использовать внешний MIDI-синтезатор, выберите порт выхода MIDI (обычно он называется "MIDI UART" или схожим образом) и убедитесь что синтезатор правильно подключен к MIDI-выходу звуковой карты.

Обратитесь к описанию Диалога Опции чтобы прочитать об остальных опциях.


Дополнительные темы
Страницы этого раздела посвящены более сложным приемам, используемым для улучшения качества распознавания WIDI.


Как работает WIDI
Распознавание музыки производится в несколько этапов.

На первом вычисляются спектральные данные специального вида, этот этап называется преобразованием "Звук->Тон". В настоящее время в программе имеются три различных алгоритма, осуществляющих это преобразование; каждый из них имеет свои достоинства и недостатки.

Далее, спектральные данные умножаются на соответствующие коэффициенты "Эквалайзера", в результате какие-то тоны становятся тише, какие-то громче.

На третьем шаге из полученного спектра выделяются собственно ноты, этот процесс называется "Тон->MIDI" и он может быть произведен с помощью одного из двух алгоритмов.

На конечной стадии создается структура будущего MIDI-файла, и Вы можете указать для него некоторые атрибуты.


Настройка Эквалайзера
Рекомендуется прочитать раздел Как работает WIDI перед настройкой Эквалайзера.
Чтобы вызвать окно Эквалайзера, выберите пункт меню Опции->Показать Эквалайзер или нажмите кнопку [image] Показать Эквалайзер на панели инструментов.
Также Вы можете использовать уменьшенное изображение Эквалайзера в правом нижнем углу основного окна WIDI. Нажатие на него вызывает окно Эквалайзера [image].

Задача Эквалайзера - дать возможность установить относительную громкость нот различных высот. Он состоит из набора регуляторов с изображенной под ними клавиатурой фортепиано. Нажимая левую кнопку мыши на области соответствующей регуляторам можно подстраивать громкость соответствующей ноты. В приведенном ниже примере все ноты имеют максимальную громкость за исключением C-1, громкость которой установлена на 56%:

Часто Эквалайзер используется для того, чтобы заглушить басовые ноты до нуля (они зачастую содержат много шума) и оставить только мелодические ноты:

Другой способ - это оставить только диатонические ноты, например здесь будут распознаны только диатоники до мажора:

Зачастую использование Эквалайзера позволяет сильно улучшить качество распознавания.

Установки Эквалайзера могут быть сохранены в файл с расширением .weqp с помошью функции сохранения установок.


Использование GS-файлов
Алгоритм WIDI состоит из двух шагов (см. детали на странице Как работает WIDI). На первом шаге, "Звук->Тон", вычисляются спектральные данные и этот процесс занимает много времени. После этого происходит конвертация в MIDI, с помощью быстрого преобразования "Тон->MIDI". Идея заключается в сохранении промежуточных спектральных данных в файл, что позволит пропускать первый шаг при изменении установок. GS - это промежуточный файл, содержащий "Тональные" данные. Вы можете создать его один раз и использовать с разными установками преобразования "Тон->MIDI" и иногда Эквалайзера.

Создание GS-файлов регулируется закладкой Обработка диалога Основные Опции.

GS-файл может быть сохранен на диске для дальнейшего использования, также как и любой другой файл.

Детальное описание можно прочесть на странице Окно GS.


Параметры распознавания записей
WIDI предоставляет множество установок и настроек для повышения качества распознавания каждой конкретной композиции. Вы можете выбирать алгоритмы распознавания и их настройки для проведения обоих этапов процесса распознавания. Здесь приведены некоторые рекомендации, которые тем не менее не являются исчерпывающими. Обычно для значительного увеличения качества необходимо поэкспериментировать с различными настройками. Относящуюся к теме информацию можно также найти в разделах Настройка Эквалайзера и диалог Параметры Распознавания.


Выбор алгоритма Звук->Тон
Временной шаг. мс - минимальное количество времени, рассматриваемое алгоритмом распознавания. Длительность ноты и время ее начала всегда равно целому числу Временных шагов.
Уменьшение этого параметра всегда приводит к увеличению объема памяти, требуемого для распознавания, а в случае использования БПФ еще и к увеличению времени вычислений. Рекомендуемый диапазон значений для этого параметр - 7...40 мс.

Улучшенные Сенсоры
Этот метод относительно быстрый. В нем применен сложный алгоритм автоподстройки и фильтрации гармоник. Это позволяет получать очень малое количество бесполезных нот - сравните GS-диаграмму изготовленную при помощи Улучшенных Сенсоров и при помощи метода из WIDI 2.5. Тем не менее методу свойственен недостаток - слабые ноты могут быть утеряны на самой первой стадии процесса распознавания. Когда имеется основной голос, более громкий чем аранжировка, и стоит задача распознать только этот голос, тогда стоит применять этот метод.

Автоподстройка - автоподстройка сенсоров в соответствии с точными значениями гармоник, присутствующих в исходном звуке. Полезна, когда аудио-файл, который Вы распознаете, исполнен на инструментах, настроенных со сдвигом относительно стандартных частот.

Фильтр гармоник - уменьшает количество обертонов, которые были бы приняты за отдельные ноты.

Одноголосый Режим - детектирует в исходном файле только самые громкие ноты. Рекомендуется использовать при распознавании одноголосых произведений.

Временной сдвиг басов исправляет время начала звучания басовых нот относительно высоких. Сенсоры как правило сдвигают басовые ноты вперед по времени, а увеличение этого параметра позволяет сдвинуть их обратно. Так что если Вы слышите, что басовые ноты начинают звучать с запаздыванием относительно высоких, попробуйте изменить этот параметр. приемлемые значения как правило лежат в диапазоне 0...40%.

Корреляторы
Это новый алгоритм, предназначенный для распознавания только одноголосых мелодий. Его устройство кардинально отличается от устройства Сенсоров.

Автоподстройка - автоподстройка сенсоров по высоте в соответствии с точными значениями гармоник, присутствующих в исходном звуке. Полезна, когда аудио-файл который Вы распознаете исполнен на инструментах, настроенных со сдвигом относительно стандартных частот (например, пение без аккомпанемента).

Сенсоры
Этот алгоритм впервые появился еще в WIDI 2.5. Как правило в результате его работы получается больше нот, чем при использовании Улучшенных Сенсоров, поэтому его рекомендуется использовать когда Улучшенные Сенсоры пропускают ноты.

Временной сдвиг басов исправляет время начала звучания басовых нот относительно высоких. Сенсоры, как правило, сдвигают басовые ноты вперед по времени, а увеличение этого параметра позволяет сдвинуть их обратно. Так что если Вы слышите, что басовые ноты начинают звучать с запаздыванием относительно высоких, попробуйте изменить этот параметр. Приемлемые значения как правило лежат в диапазоне 0...40%.

БПФ
Это старый алгоритм, основанный на Быстром Преобразовании Фурье. В целом, Сенсоры работают почти всегда лучше чем БПФ, за исключением случая, когда пьеса исполняется на неправильно настроенных инструментах (например, нота До лежит на четверть тона выше, чем стандартное "До").

Временной сдвиг басов - исправляет время начала звучания басовых нот относительно высоких. БПФ сдвигает начала басовых нот на более раннее время, чем следует, а увеличение параметра "Временной Сдвиг" сдвигает их обратно. Поэтому, если Вы слышите что басовые ноты звучат до высоких, попробуйте изменить этот параметр. Приемлемые значения лежат в диапазоне 0...70%.


Выбор алгоритма Тон->MIDI
Минимальная длина ноты - этот параметр помогает избавиться от коротких неправильных нот в результирующем MIDI-файле. Алгоритм просто стирает все ноты, длительность которых меньше этого значения. Подходящее значение зависит от жанра произведения; в основном оно лежит в диапазоне 20...150 мс.

Способ поиска нот - этот переключатель задает тип алгоритма, используемого на втором шаге. Пиковый - это более новый метод, а Локальный - более старый, тем не менее Вы можете попробовать применить оба.

Полифония задает число голосов в итоговом файле. Этот параметр трактуется по-разному разными методами, поэтому для каждого метода имеется свой регулятор. Этот параметр позволяет контролировать число голосов в результирующем файле.


Типичные случаи
Для начала, попробуйте использовать параметры установленные по-умолчанию. Здесь приведены некоторые типичные изменения установок которые помогут улучшить качество распознавания.

Медленная мелодия
Попробуйте увеличить параметр Минимальная Длина Ноты до 80...150 мс.

Монофоническое (одноголосое) произведение
Используйте либо Улучшенные Сенсоры с включенным флажком Одноголосье, либо Корреляторы или БПФ со значением Полифония = 1.

Большое количество неправильных нот, вызывающих диссонанс
Используйте алгоритм с возможностью автоподстройки либо БПФ. Используйте Пиковый способ детекции нот.

Басовые/ударные заглушающие основной голос
Используйте Эквалайзер для приглушения басовых нот.

Много неверных высокочастотных нот
Используйте Эквалайзер или фильтр гармоник алгоритма Улучшенные Сенсоры.

Басовые ноты задерживаются относительно высоких
При использовании алгоритма БПФ - сдвиньте ползунок Временной сдвиг басов налево, для остальных алгоритмов - вправо.

Слишком много неправильных голосов
Уменьшите параметр Полифония.

Многие ноты "проглочены"
Попробуйте увеличить параметр Полифония, не используйте метод Улучшенные Сенсоры или выключите фильтр гармоник.


Параметры распознавания в реальном времени
Алгоритмы для распознавания в реальном времени несколько отличаются от тех, которые используются для распознавания записей. Эта страница описывает различия.

Также существует разница между нотами, которые проигрываются при распознавании в реальном времени, и теми, которые в результате записываются в MIDI-файл. Установки параметра Минимальная длина ноты используются только при создании файла, так как длина ноты не может быть определена когда нота только начала звучать. По той же причине, все ноты, проигрываемые при распознавании в реальном времени имеют одинаковую громкость.

Распознавание в реальном времени использует специальный алгоритм преобразования Тон->MIDI. Установки параметра Минимальная длина ноты используются только при создании файла, все прочие параметры закладки Тон->MIDI игнорируются. Настройки MIDI-файла берутся из диалога Опции MIDI.

Установка большинства параметров распознавания в реальном времени производится непосредственно в окне модуля Распознавание в реальном времени.

Порог шума задает абсолютный порог обрезания нот. Все ноты тише чем порог шума отбрасываются.

Рекомендуется поэкспериментировать с настройками распознавания в реальном времени, чтобы достигнуть наилучшего качества.

Алгоритмы распознавания в реальном времени

Полифонический - Сенсоры - то же самое что и 'Улучшенные Сенсоры" при распознавании записей.
Полифония задает относительный уровень отбрасывания для одновременно звучащих нот. Чем больше это значение, тем больше нот могут звучать одновременно.

Одноголосье - Корреляторы это новый алгоритм, для одноголосья использующий корреляторы. Дополнительных настроек у него нет.

Одноголосье - Сенсоры одноголосый вариант алгоритма Сенсоры.
Фильтр гармоник - позволяет исправить ситуацию, когда обертона считаются нотами, но установка этого параметра на слишком большую величину может привести к ситуации, когда практически все требуемые ноты будут пропущены.


Поиск оптимальных наборов установок
Наборы установок для распознавания (см. Параметры распознавания) могут быть легко сохранены в файлы и восстановлены из файлов, см Сохранение настроек. Это позволяет пользователям обмениваться установками, оптимальными для распознавания того или иного типа музыкальных произведений.

На нашем сайте вы можете найти пополняемую коллекцию настроек по адресу http://www.widisoft.com/russian/presets.html.
Мы также приглашаем вас делиться с нами вашими удачными наборами настроек, чтобы мы могли добавить их к нашей коллекции.


Основное окно
Основное окно лежит в основании всех остальных окон WIDI и служит рабочим пространством для всех модулей WIDI. Оно так же содержит быстрые вызовы функций, которые либо универсальны, либо общие для многих дочерних окон WIDI. В Обзоре меню содержится полный список команд меню.

Большинство функций WIDI доступно из панели инструментов:
кнопка Открыть открывает новый файл. В появившемся диалоге выберите соответствующий фильтр из списка, чтобы открыть файлы различного типа.
Закрыть закрывает окно, активное в данный момент.
Сохранить сохраняет активный файл. Замечание: Эта функция в незарегистрированной версии всегда отключена.
Запись вызывает модуль Записи звука, при помощи которого можно записать новый звуковой файл.
В реальном времени открывает модуль Распознавания в реальном времени.
Опции открывает диалог Опции, позволяющий изменять установки программы.
Настройки открывает диалог Настройки распознавания, где вы можете установить параметры распознавания.
Эквалайзер вызывает Эквалайзер, задача которого - отфильтровывать нежелательные частотные диапазоны во время процесса распознавания.
Микшер Windows вызывает стандартный Микшер Windows.
Расположить размещает все дочерние окна специальным образом.

Уменьшенное изображение [image] в статусной строке служит для напоминания о текущих установках Эквалайзера и может быть использовано для его вызова.


Окно аудио
Окно аудио отображает аудио (Wave, MP3, аудио-CD и других форматов) в виде звуковой волны. Окно аудио открывается при загрузке аудио записи с диска или после записи звука с помощью модуля записи. Может быть открыто только одно Окно аудио.

Проиграть Все проигрывает всю запись целиком.
Проиграть выделенное проигрывает выделенный фрагмент.
Пауза приостанавливает проигрывание.
Стоп останавливает проигрывание.
Распознать запускает распознавание выделенного фрагмента.
Выделить от начала помещает начало выделения на начало записи.
Выделить до конца помещает конец выделения на конец записи.
Левый канал выбирает для распознавания левый канал стерео-записи.
Правый канал выбирает для распознавания правый канал стерео-записи.
Сумма каналов выбирает для распознавания сумму левого и правого каналов стерео-записи. Этот вариант использовался предыдущими версиями WIDI.
Разность каналов выбирает для распознавания разность левого и правого каналов стерео-записи, что может быть для удаления основного голоса с целью изготовления записей для караоке.
Регуляторы выделения [image] и [image] показывают время начала и конца выделения.
Длительность также работает как кнопка "Выделить все".

Выделение фрагмента записи - нажмите основную кнопку мыши над изображением волны, двигайте мышь, отпустите кнопку для завершения выделения.

Замечание: WIDI сохраняет все аудио-файлы в формате 16 бит Моно или Стерео 22050 Гц. Будьте внимательны, чтобы не перезаписать исходный файл.


Окно MIDI
Окно MIDI соответствует MIDI-композиции (расположенной в памяти или на диске). Оно также используется как простой Проигрыватель MIDI. Окно MIDI автоматически появляется после завершения процесса распознавания или после редактирования данных с помощью редактора TrueTone. Также Вы можете открыть MIDI-файл с диска.

Проиграть проигрывает композицию.
Пауза приостанавливает проигрывание.
Стоп останавливает проигрывание.
Проиграть синхронно проигрывает MIDI-композицию одновременно с исходным файлом, или, если идентифицировать источник не удается - одновременно с открытой в настоящее время аудио-записью.
Транспонировать позволяет транспонировать всю MIDI-композицию на произвольное число полутонов.
Установить инструмент позволяет указать инструмент которым следует проигрывать MIDI-композицию.
Вызвать редактор TrueTone вызывает редактор TrueTone для текущей MIDI-композиции. Данные MIDI копируются в редактор и редактирование не влияет на содержимое Окна MIDI. Если соответствующие спектральные данные не обнаружены, Редактор TrueTone запускается в режиме "только MIDI". Эта кнопка недоступна в WIDI Standard.
Свойства MIDI открывает диалог Свойства MIDI-файла для текущей композиции.

Замечание: Если Вы планируете редактировать композицию с помощью редактора TrueTone позже, следует открыть редактор после распознавания и сохранить результаты в виде "Файла Редактора TrueTone".


Окно редактора TrueTone(tm)
Редактор TrueTone - это специализированный редактор MIDI, включенный в WIDI Professional. Он позволяет быстро и эффективно корректировать результаты автоматического распознавания. Для детального рассмотрения функций редактора читайте раздел Интерфейс редактора TrueTone.


Окно GS
Окно GS содержит GS-файл, предназначенный для необязательного промежуточного шага распознавания и используемый для ускорения повторного распознавания.

Кнопка [image] Распознать запускает последний этап процесса распознавания и выдает MIDI-файл. Двойной щелчок по изображению спектра также запускает его распознавание.


Запись звука
Модуль Запись Звука представляет из себя простейшую звукозаписывающую программу. В разделе Запись Звука находится список возможностей и рекомендации по использованию.
Модуль Записи Звука можно вызвать выбрав пункт меню "Файл->Запись Звука" или нажав на кнопку [image] Запись звука на панели инструментов основного окна.

Кнопка [image] Подготовить подготавливает диск для немедленной записи. Если Вы не используете временные файлы (см Установка Опций), программа спросит у Вас имя файла. Используйте эту кнопку если Вы не хотите никаких задержек после нажатия кнопки Запись.
Кнопка [image] Запись начинает запись. Если Вы не используете временные файлы (см Установка Опций), программа спросит у Вас имя файла.
Пауза приостанавливает запись до тех пор пока Вы не нажмете кнопку Запись для возобновления. После возобновления запись продолжится с текущей позиции.
Стоп останавливает запись.
Микшер Windows - вызывает стандартный Микшер Windows для подстройки уровня записи.
Отсчетов в сек. - выберите из списка частоту дискретизации будущего файла.
Разрешение - Вы можете установить число бит на один отсчет с помощью переключателя.
Каналы - выберите, монофонический или стереофонический файл будет записываться.
Указатель уровня позволяет Вам отслеживать уровень звука в процессе записи для подстройки уровня записи.
флажок Уровень включает и выключает Указатель уровня. Как правило, другие приложения не могут записывать звук пока этот выключатель включен.
Кнопка Помощь открывает эту страницу файла помощи.
Кнопка Готово закрывает модуль записи звука и загружает записанный звук в Окно Аудио.
Отмена не загружает записанный звук в WIDI. Если запись производилась во временный файл, она стирается.

Замечание: Если вы собираетесь использовать записанный файл только в текущей версии WIDI, Вам нет необходимости устанавливать качество записи выше чем 16 бит стерео 22050 Гц.


Распознавание в реальном времени
Модуль распознавания в реальном времени позволяет производить запись как с микрофона так и с любого другого входа, выбранного в пункте источник звука и одновременно осуществлять преобразование звука в формат MIDI в соответствии с текущими установками распознавания.
Модуль распознавания в реальном времени вызывается кнопкой [image] В реальном времени панели инструментов основного окна.

Запись MIDI запускает запись распознанных MIDI нот.
Авто-запись начинает запись MIDI как только появляется первая нота.
Стоп останавливает запись. Повторное нажатие кнопки Запись MIDI приведет к потере предыдущей записи и начале новой.

Опции - Вызывает диалог Опции и позволяет выбрать Устройство ввода аудио.
Кнопка [image] Установки позволяет установить Установки распознавания в реальном времени и атрибуты MIDI-файла.
Эквалайзер вызывает окно Эквалайзера. Установки Эквалайзера срабатывают немедленно, вам нет необходимости закрывать окно для этого.
Микшер Windows - позволяет вам настроить системный Микшер.

Также доступны следующие опции и установки:

Флажок Распознавать включает распознавание поступающего звука.
Флажок Играть ноты включает непосредственное проигрывание распознанных нот.
Индикатор Записанные данные - показывает длительность записанной MIDI-последовательности.

Кнопка Алгоритм позволяет выбрать один из нескольких алгоритмов распознавания. Выбранный алгоритм имеет дополнительные настройки.
Ползунок Полифония появляется при выборе алгоритма "Полифонический - Сенсоры" Он позволяет регулировать порог, определяющий число одновременно звучащих нот.
Ползунок Фильтр гармоник появляется при выборе алгоритма "Одноголосье - Сенсоры". Он предотвращает распознавание обертонов вместо основных частот.
Ползунок Порог шума позволяет настроить фильтр шума, чтобы предотвратить распознавание нежелательных звуков как нот. Настраивайте его аккуратно, чтобы не потерять существенных нот.

Индикатор Уровня показывает уровень поступающего звука, который можно настроить с помощью системного микшера (см кнопку Микшер Windows). Рекомендуемое пиковое значение лежит в пределах -15...-5 Дб.

Вы можете подстраивать параметры распознавания не прерывая процесса распознавания; все изменения вступают в силу как только они производятся. Тем не менее, при включенной записи MIDI некоторые настройки становятся недоступны.

Для завершения распознавания и работы с распознанным MIDI нажмите Готово. Новый файл будет открыт в новом MIDI-окне.

Чтобы отменить распознавание нажмите Отменить.


Диалог Опции
Диалог Опции устанавливает различные опции WIDI, не связанные непосредственно с процессом распознавания. Этот диалог вызывается нажатием кнопки [image] Основные Опции. Общие рекомендации по их настройке можно прочесть на странице Установка Опций.

Диалог Опции состоит из трех закладок:

Закладка Основные - устанавливает параметры интерфейса и автосохранения.

Закладка Обработка - управляет созданием GS- и временных файлов.

Закладка Устройства - устанавливает устройства ввода/вывода звука.

Кнопка OK подтверждает сделанные изменения, Отменить - отменяет их, Сбросить устанавливает параметры всех трех закладок в значения по умолчанию, Помощь вызывает контекстную справку.


Закладка Основные
Общие рекомендации по настройке опций можно прочесть на странице Установка Опций.

Подтверждения
Вы можете включить/отключить запрос подтверждения на:
Сохранять Wave - закрытие временного файл с аудио-записью.
Закрыть предыдущий файл - закрытие предыдущей записи при открытии новой.
Сохранять GS - закрытие временного GS-файла.
Сохранять MIDI - закрытие распознанного MIDI-файла.

Интерфейс
Флажок Запускать Мастер заставляет программу при старте включать Мастер распознавания.
Опция Крупные иконки регулирует размер иконок на кнопках панели инструментов.

Автосохранение
Вы можете включить автоматическое сохранение Опций, Настроек распознавания и установок Эквалайзера при закрытии WIDI.


Закладка Обработка
Общие рекомендации по настройке опций можно прочесть на странице Установка Опций.

При обработке аудио
Эти флажки определяют, будет ли WIDI создавать только MIDI-файлы (Создавать GS-файлы выключен), только GS-файлы (оба включены) или и те и другие (Создавать GS-файлы включен).

Временные файлы
Запись во временные файлы заставляет WIDI использовать временный файл при записи аудио. В противном случае программа спросит у вас имя файла для записи.
Развертывать сжатые файлы во временные приводит к тому, что WIDI создает временный файл с декомпрессированным звуком при открытии MP3 или сжатых Wave фалов.
Считывать CD во временные файлы - включает первоначальное копирование CD на жесткий диск для последующего доступа с целью проигрывания или распознавания.
Директория для временных файлов - Вы можете указать директорию для хранения временных файлов.
Стереть все стирает временные файлы, созданные WIDI, из приведенной директории.

В разделе Временные файлы можно найти больше информации об их использовании.


Закладка Устройства
Общие рекомендации по настройке опций можно прочесть на странице Установка Опций.

Выпадающие списки Устройство ввода аудио, Устройство вывода аудио и Устройство вывода MIDI позволяют выбрать соответствующие устройства из списка доступных. По умолчанию выбраны Wave Mapper и MIDI Mapper. Вы можете изменить их если хотите использовать другие устройства или драйверы.

В разделе Установки устройств ввода/вывода можно найти больше информации о выборе устройств.


Параметры распознавания
Диалог Параметры распознавания устанавливает различные параметры алгоритмов распознавания WIDI.
Диалог Параметры распознавания вызывается кнопкой [image] Настройки где вы можете установить параметры распознавания. На странице Настройка параметров распознавания имеются общие рекомендации по выбору алгоритмов и настройке параметров.

Диалог Параметры распознавания состоит из трех закладок:

Закладка "Звук->Тон" - устанавливает алгоритм для преобразования "Звук->Тон" и его параметры.

Закладка "Тон->MIDI" - устанавливает алгоритм для преобразования "Тон->MIDI" и его параметры.

Закладка Опции MIDI - устанавливает параметры для всех вновь создаваемых MIDI-файлов.

Кнопка OK подтверждает сделанные изменения, Отменить - отменяет их, Сбросить устанавливает параметры всех трех закладок в значения по умолчанию, Помощь вызывает контекстную справку.

Установки позволяют сохранять в файл с расширением .wset все параметры распознавания (включая установки Эквалайзера) и считывать их из этих файлов. Подробнее см. раздел установки.


Закладка Звук->Тон
На странице Настройка параметров распознавания имеются общие рекомендации по выбору алгоритмов и настройке параметров.

Временной шаг, мс - минимальное количество времени, рассматриваемое алгоритмом распознавания. Длительность ноты и время ее начала всегда равно целому числу Временных шагов.

Список Метод определения тона позволяет выбирать различные алгоритмы для преобразования Звук->Тон. Каждый алгоритм имеет собственные настройки, которые отображаются на панели справа. Детальное объяснение всех алгоритмов приведено на странице Выбор алгоритма Звук->Тон.


Закладка Тон->MIDI
На странице Настройка параметров распознавания имеются общие рекомендации по выбору алгоритмов и настройке параметров.

Минимальная длина ноты - этот параметр помогает избавиться от коротких неправильных нот в результирующем MIDI-файле. Алгоритм просто стирает все ноты, длительность которых меньше этого значения. Подходящее значение зависит от жанра произведения; чаще всего оно лежит в диапазоне 20...150 мс.

Разделять треки по громкости - если этот переключатель включен, одновременно звучащие ноты сортируются по громкости по трекам. При выключенном флажке все ноты помещаются на один трек.

Способ поиска нот - этот переключатель задает тип алгоритма, используемого на втором шаге. Пиковый - это более новый метод, а Локальный - более старый, тем не менее Вы можете попробовать применить оба.

Полифония задает число голосов в итоговом файле. Этот параметр трактуется по-разному разными методами, поэтому для каждого метода имеется свой регулятор. Этот параметр позволяет контролировать число голосов в результирующем файле.


Закладка Опции MIDI
Закладка Опции MIDI устанавливает параметры для всех вновь создаваемых MIDI-файлов.

Эти параметры не влияют на процесс распознавания; тем не менее они определяют некоторые атрибуты создаваемого MIDI-файла. Все они, кроме параметра Инструмент, не влияют на звучание файла.

Инструмент - текущая версия WIDI не умеет автоматически определять инструменты, но Вы можете приписать распознаваемым нотам любой инструмент.
Тональность - Вы можете назначить любую тональность для получаемой MIDI-композиции. Это не приводит к ее транспонированию.
Размер - Вы можете установить размер MIDI-композиции с помощью этого параметра (2/4, 3/4, 3/8 и так далее).
Темп - устанавливает темп композиции по умолчанию.


Эквалайзер
Задача Эквалайзера - дать возможность установить относительную громкость нот различных высот, или даже исключить из рассмотрения ноты определенных частот. Детальное описание можно найти в разделе Настройка Эквалайзера.
Чтобы вызвать окно Эквалайзера, выберите пункт меню Опции->Показать Эквалайзер или нажмите кнопку [image] Эквалайзер на панели инструментов. Также Вы можете использовать уменьшенное изображение Эквалайзера в правом нижнем углу основного окна WIDI. Нажатие на него вызывает окно Эквалайзера [image].

В заголовке показывается выделенная нота, ее частота и относительная громкость.
Замечание: Октавы WIDI соответствуют стандартным октавам в MIDI плюс 3.

Флажок Поверх всех окон определяет, будет ли Эквалайзер находиться поверх остальных окон WIDI.

Кнопки 0%, 50% и 100% выставляют все регуляторы в соответствующее положение. Замечание: поскольку Эквалайзер управляет относительной громкостью, кнопки 50% и 100% приводят к одинаковому эффекту. Используйте эти позиции как промежуточные при настройке Эквалайзера.

Нажимая в область над клавиатурой Вы выставляете громкость соответствующей ноты. Двойной щелчок по ноте на клавиатуре приводит к установке ее в максимум либо минимум.

Чтобы прослушать отдельную ноту, нажмите на соответствующую клавишу клавиатуры, удерживая Shift.

Установки позволяют сохранять в файл с расширением .weqp установки Эквалайзера считывать их из таких файлов. Подробнее см раздел сохранение настроек.


Стартовый диалог
При запуске незарегистрированной версии WIDI сначала появляется следующий диалог:

Купить через Интернет открывает Страницу регистрации с помощью основного броузера.
Ввести код открывает Диалог регистрации, в котором Вы можете ввести регистрационную информацию.
ОК - запустить программу в тестовом режиме - в нем допускается сохранение не более 10 секунд MIDI.

Замечание: В соответствии с Лицензионным Соглашением Вы не можете пользоваться незарегистрированной программой дольше чем в течении 14-ти дней начиная с даты инсталляции.


Свойства MIDI-файла
Диалог Свойства MIDI-файла устанавливает параметры текущего MIDI-фала. Этот диалог может быть вызван из Окна MIDI или Редактора TrueTone.

Эти параметры не влияют на процесс распознавания, тем не менее они определяют некоторые атрибуты создаваемого MIDI-файла.

Строка копирайта - эта строка записывается в MIDI-файл в качестве информации о копирайте.
Тональность - Вы можете назначить любую тональность для получаемой MIDI-композиции. Это не приводит к ее транспонированию.
Размер - Вы можете установить размер MIDI-композиции с помощью этого параметра ((2/4, 3/4, 3/8 и так далее).
Темп - устанавливает темп композиции.


Окно Прогресс операции
Окно Прогресс операции показывает текущее состояние операций, которые могут занять много времени.

Пауза приостанавливает обработку, возвращая системе ресурсы процессора.
Отменить прерывает операцию. Иногда реакция не мгновенна, особенно на медленных машинах.


Диалог регистрации
Диалог Регистрации используется для введения полученных после Регистрации WIDI регистрационного имени и кода. Он вызывается при помощи пункта меню "Помошь->Зарегистрировать!" либо из Стартового диалога.

Подробнее см. Введение регистрационного кода.


Сохранение настроек
Во многих диалогах программы имеется раздел "установки", позволяющий сохранять или восстанавливать текущие настройки.

Выпадающий список содержит названия установок, выбирая один из пунктов этого списка, пользователь устанавливает сразу все настройки диалога в соответствии с выбранной установкой.

Добавить предлагает ввести имя для сохранения текущих настроек.
Стереть стирает выбранную настройку из списка.

Настройки сохраняются в специальных файлах, находящихся в директории данных программы. При добавлении настройки файл с соответствующим названием появляется в этой директории, а при удалении – этот файл стирается.

Кнопка Экспорт сохраняет файл настроек в любую директорию, а кнопка Импорт позволяет прочитать файл настроек из любой директории.

Таким образом, файлы настроек могут быть перенесены с компьютера на компьютера или загружены из Интернет.

На нашем сайте вы можете найти пополняемую коллекцию настроек для распознавания по адресу http://www.widisoft.com/russian/presets.html.


Команды меню
Для Вашего удобства здесь приведен полный список команд меню.

Основное Окно
Файл
Открыть... - открыть файл.
Сохранить - сохранить текущий файл.
Сохранить как... - сохранить файл под другим именем.
Закрыть - закрыть текущий файл.
Мастер Распознавания - запустить Мастер Распознавания.
Записать звук - Записать звук.
В реальном времени - вызывает модуль распознавания в реальном времени.
Вновь открыть - открыть один из последних файлов.
Выход - выйти из WIDI.
Опции
Параметры распознавания - вызывает параметры распознавания.
Эквалайзер - вызывает Эквалайзер.
Основные Опции - вызвать диалог Основные Опции.
Микшер Windows - вызывает стандартный Микшер Windows.
Окно
Расположить - расположить окна специальным образом.
Каскадом - расположить окна каскадом.
Плиткой - расположить окна плиткой.
Расположить иконки - расположить иконки минимизираных окон.
Свернуть все - свернуть все окна.
Помощь
О программе - показать диалог О Программе.
Помощь - открывает содержание Справки.
Возможности - открывает список возможностей в файле справки.
Быстрый старт - открывает страницу Быстрый старт в файле справки.
Интернет сайт - открывает Сайт WIDI в основном броузере.
Вопросы на сайте - открывает Вопросы на сайте WIDI в основном броузере.
Форум пользователей - открывает Форум Пользователей на Сайте WIDI в основном броузере.
Зарегистрироваться - открывает Страницу регистрации.
Ввести ключ - ввести регистрационный код.
Регистрационная информация - показывает регистрационную информацию.

Редактор TrueTone
Меню редактора TrueTone рассматривается в обзоре меню нотного редактора.

Окно Аудио
Распознать
Распознать аудио - запускает процесс распознавания исходного файла.

Окно GS
Распознать
Преобразовать GS в MIDI - создает MIDI-файл из текущего GS-файла.

Окно MIDI
Редактировать
Вызвать Редактор TrueTone - открыть текущий MIDI-файл в редакторе TrueTone.
Транспонировать - транспонировать всю MIDI-композицию на произвольное число полутонов.
Сменить инструмент - указать инструмент которым следует проигрывать MIDI-композицию.
Операции
Редактировать свойства MIDI-файла - открыть диалог свойства MIDI-файла.
Связать с аудио - указать аудио-файл, из которого была получена данная MIDI-композиция.
Открыть связанный аудио-файл - открыть аудио-файл, связанный с данной MIDI-композицией.


Команды клавиатуры
Для Вашего удобства здесь приведен полный список команд клавиатуры:

Основное Окно
Ctrl+O - Открыть файл.
Ctrl+S - Сохранить текущий файл.
Ctrl+Shift+S - Сохранить файл под другим именем.
Ctrl+R - Записать Аудио.
Ctrl+T - Вызывает Модуль Распознавания в Реальном Времени.
Ctrl+Q - Выйти из WIDI.
Ctrl+W - Разместить окна.
F1 - Открывает Справку.

Редактор TrueTone
Комманды клавиатуры редактора TrueTone рассматривается в обзоре команды клавиатуры нотного редактора.

Окно Аудио
Пробел - Проиграть/Остановить.
Ctrl+Enter - Распознать выделенный участок.

Окно GS
Ctrl+Enter - Распознать.

Окно MIDI
Пробел - Проиграть/Остановить.
Ctrl+Enter - Открыть редактор TrueTone.

Эквалайзер
Двойной щелчок по ноте на клавиатуре - установить ее в 0% или 100%.
Shift+щелчок по ноте на клавиатуре - проиграть ее.

Модуль Записи звука
"R" - Начать/Остановить запись.

Модуль Распознавания в реальном времени
"A" - Авто-Запись.
"R" - Начать/Остановить запись.


Задача редактора TrueTone(tm)
Редактор TrueTone(tm) - это специализированный редактор MIDI, включенный в WIDI Professional. Он позволяет быстро и эффективно корректировать результаты автоматического распознавания. Редактор устроен по принципу Piano Roll, т.е. ось времени расположена горизонтально, а разные позиции по вертикали соответствуют разной высоте тона.

Уникальное отличие редактора TrueTone от других аналогичных редакторов заключается в том, что Область редактирования сочетает в себе спектрограмму исходного музыкального произведения и распознанные ноты. Таким образом, редактор TrueTone позволяет визуально сравнивать пики на спектрограмме (отображаемые цветом) с нотами. Поскольку максимальные значения на спектрограмме, как правило, соответствуют нотам, такая схема очень удобна для редактирования распознанных файлов, так как позволяет успешно редактировать результаты распознавания, даже если у Вас нет большого опыта работы с музыкой.

Среди прочих функций редактора TrueTone присутствуют возможности добавления и стирания нот, изменения их высоты и длительности, проигрывания результата, включая синхронное проигрывание одновременно с исходным аудио-файлом. Также редактор позволяет расставлять тактовые черты – как вручную, так и на слух, с помощью инструмента Теппинг. Редактор располагает средствами для работы с треками и широкими возможностями группировки и совместного редактирования нот.

Редактор TrueTone позволяет сохранять результаты в файл специального формата (.wne), который содержит как ноты так и спектрограмму, а также экспортировать ноты в MIDI файл.


Множественное выделение
Редактор TrueTone обладает широкими возможностями для редактирования нот. Время начала, высоту и длительность можно изменять в визуальном режиме, двигая ноты и меняя их размер. Используемый инструмент, громкость и другие параметры нот могут быть изменены с помощью диалога Свойства ноты.

Множественное выделение позволяет выделить любую группу нот и изменять их свойства одновременно, что может сильно облегчить задачи разбиения полученного произведения на голоса, изменения используемого инструмента или громкости всего произведения и отдельных его частей, и другие. Выделение нот подчиняется стандартным для Windows правилам – так, возможно и добавлять ноты по одной к уже выделенным, и выделить курсором мыши часть области редактирования. Кроме того, редактор позволяет выделить все ноты лежащие в определенном временном или частотном диапазоне, выделяя участок линейки времени или фортепианной клавиатуры.

Помимо изменения свойств, с выделенными нотами можно производить и другие стандартные операции – копировать, стирать, вырезать. Кроме того всю выделенную группу нот можно временно заглушить, что позволяет прослушать произведение без этих нот, не стирая их. Все сделанные шаги могут быть отменены с помощью функции "отменить" и повторены вновь с помощью функции "повторить", причем количество запоминаемых шагов не ограничено.

Группа нот может быть выделена и с использованием более сложных условий, для чего служит Фильтр нот. Этот инструмент позволяет задать диапазоны изменения любых параметров нот, и будут выделены ноты, удовлетворяющие этому условию. Данная возможность позволяет изменять, например, максимальную разницу в громкости нот в произведении, стирать слишком короткие или слишком тихие ноты и производить другие глобальные операции над произведением в целом.

Поведение селекции является настраиваемым, закладка Фокусировка диалога Свойства редактора позволяет изменять поведение редактора относительно фокусировки и операций отмены и повтора.


Редактор треков
MIDI файл всегда состоит из одного или более треков. Ноты, принадлежащие одному треку, при экспорте в любой нотный редактор оказываются представлены как отдельный голос. Как правило, всему треку назначается один инструмент.
Редактор TrueTone, содержит встроенную панель для работы с треками - Редактор треков. Помимо стандартных функций, таких как присвоение треку названия и заглушения всех его нот, Редактор треков позволяет также выделять все ноты входящие в данный трек, а также прятать, не заглушая, все ноты определенного трека.

Полезной может оказаться возможность раскраски каждого трека в свой цвет. По умолчанию цвета всех нот выставляются в соответствии с текущей цветовой схемой, но используя Редактор треков можно установить для каждого трека свой цвет, и эта раскраска сохраняется в файле вместе с самим произведением.


Тактовые черты
Музыкальные произведения в основе своей ритмической структуры имеют такты. Такт делится на несколько (обычно 2,3,4,6 - в зависимости от размера) долей, и, чаще всего, сильная доля совпадает с началом такта. Длительность такта может меняться только вместе с темпом. В живой музыке не встречается двух тактов абсолютно одинаковой длительности, так как темп исполнения постоянно слегка изменяется, подчеркивая те или иные нюансы. В нотной записи границы такта обозначаются тактовой чертой, причем обозначения для длительностей нот зависят от расположения тактовых черт и деления такта на доли. Например, если нота длиной в четверть началась в самом начале такта в размере 4/4, то она будет обозначена одной четвертной нотой. Если же она началась за 1/8 до конца такта, то правила нотной записи требует обозначить ее как две восьмые ноты, соединенные через тактовую черту знаком "легато", хотя в обоих случаях нота звучит одинаково. Ноты, пересекающие границу такта, встречаются в музыке не очень часто.

При открытии MIDI файла любым нотным редактором, сначала проводится процедура квантования, которая и позволяет разделить произведение на такты и расставить тактовые черты. При этом позиция и длительность для всех нот устанавливаются в ближайшее кратное длительности 1/32 или 1/16 значение (этот параметр обычно настраиваемый), после чего расставляются тактовые черты. В большинстве случаев, пользователю позволяют самому выбрать размер и темп, но это оказывается не очень полезно – при такой "автоматической" расстановке тактовых черт очень многие ноты оказываются пересекающими границы тактов и долей, и нотная запись получается неудобной для чтения и исполнения. Конечно, можно попытаться отредактировать такую запись прямо в нотном редакторе, сдвигая ноты таким образом, что бы они не пересекали границы тактов, но в этом случае мы изменяем звучание произведения. Между тем, на самом деле неправильно расставлены не ноты, а наоборот – тактовые черты. Что можно предпринять в этой ситуации?

MIDI до некоторой степени поддерживает точное позиционирование тактовых черт. Это достигается многократным использованием команды смены темпа. Используя эту технику, удается записать тактовые черты в MIDI файл, с некоторыми ограничениями*.

Редактор TrueTone позволяет расставлять тактовые черты двумя способами. Во-первых, их можно добавлять, стирать и передвигать в визуальном режиме. Это может быть удобно в произведении со сложной ритмической структурой. Другой метод – это воспользоваться инструментом Теппинг, который позволяет расставить тактовые черты на слух, причем ориентируясь не только на звучание распознанного MIDI, но и на звучание оригинала. Расставленные таким образом тактовые черты также можно откорректировать в визуальном режиме. Редактор также позволяет изменять разметку на линейке времени, отображая на ней либо время от начала произведения, либо номера тактов.

*Замечание: При появлении слишком длинных (более 5 сек) тактов, при экспорте в MIDI, такие участки заполняются тактами одинаковой длины, в соответствии со значением темпа, указанным в свойствах MIDI-файла. Слишком короткие (менее 0,25 сек) – автоматически сливаются с соседним тактом.


Дополнительные возможности
Редактор TrueTone предоставляет широкие возможности для настройки его внешнего вида и поведения.
Инструменты и панели инструментов являются перемещаемыми, что позволяет прикреплять их к любой границе окна, оставлять плавающими поверх основного окна, а также прятать. Количество и расположение кнопок на панелях инструментов можно изменять, пользуясь контекстным меню.

Помимо этого, пользователь может редактировать цветовую схему редактора, с помощью диалога Настройка цвета. Диалог позволяет выставлять любые цвета для отображения подложки, границ нот в выделенном и невыделенном состоянии, а также цвета, которыми отображается спектрограмма. Цветовые настройки могут быть сохранены в файл или загружены из файла.

Кроме редактирования, редактор позволяет изменять масштаб отображения независимо по времени и по высоте. Окно Карта нот позволяет видеть все произведение и ту его часть, которая в данный момент отображается в области редактирования, а также изменять отображаемую позицию.

Диалог Опции редактора TrueTone позволяет настраивать поведение редактора в различных ситуациях. Можно настроить позицию фокусировки на выделенной области, особенности поведения истории операций и установки по умолчанию для режима селекции, а также другие свойства.


Основное окно
Основное окно редактора TrueTone состоит из нескольких областей. Расположение инструментов можно изменять, но по умолчанию редактор выглядит так, как показано на рисунке:

Область редактирования – это основная часть редактора, на которой отображаются ноты, наложенные на спектрограмму исходного произведения, предназначенная для визуального редактирования нот. См. Область редактирования .
Карта нот отображает все произведение целиком, и позволяет отобразить в области редактирования любую его часть. См. Карта нот .
Редактор треков – инструмент, позволяющий редактировать MIDI-данные по трекам. Он также может быть полезен для разделения MIDI-файла на голоса. См. Редактор треков.
Строка состояния – отображает параметры той ноты, над которой в данный момент находится курсор мыши, если же нет - то отображаются параметры выделенной ноты, так же как в диалоге Параметры ноты. Кроме того, справа показывается количество выделенных в данный момент нот.
Линейка – отображает шкалу времени или номера тактов. См. Линейка времени.

Панели инструментов состоит из нескольких отдельных панелей, соответствующих основным функциям редактора:
Инструменты – дает возможность выбрать инструмент для визуального редактирования.
Правка – содержит кнопки для работы с буфером нот и отмены операций.
Выделение – управляет режимами и способами выделения нот.
Проигрывание – позволяет проигрывать MIDI и исходный файл в различных режимах.
Вид – управляет масштабом отображения спектрограммы и нот в области редактирования.
Дополнительные – содержит кнопки для вызова дополнительных функций.

Пользователь может настроить интерфейс нотного редактора в соответствии со своими вкусами, в том числе изменить расположение панелей инструментов и органов управления. Кроме этого, пользователь может изменять количество кнопок и состав групп на панелях инструментов при помощи контекстного меню или пункта меню "Опции->Настройка панели инструментов редактора….".


Область редактирования
Редактор устроен по принципу клавишного редактора, т.е. ось времени расположена горизонтально а разные позиции по вертикали соответствуют разной высоте тона. Его основное окно сочетает в себе спектрограмму исходного музыкального произведения и распознанные ноты. Таким образом, редактор TrueTone позволяет визуально сравнивать пики на спектрограмме (отображаемые цветом) с нотами. Редактор TrueTone позволяет также редактировать только MIDI-файл, без спектрограммы (режим "только MIDI").

На рисунке изображен участок спектрограммы, на котором показаны две ноты, первая из которых имеет ясно видимую спектральную структуру. Нижний пик соответствует основному тону, в два верхних, отстоящие на октаву - обертонам.

Редактор позволяет визуально редактировать ноты – изменять их высоту, длительность и момент начала звучания. Поведение редактора зависит от выбранного инструмента редактирования.

Контекстное меню области редактирования

Вырезать вырезает выделенные ноты.
Копировать копирует выделенные ноты.
Вставить вставляет содержимое буфера в начало отображаемой в окне редактирования области.

Отменить пошагово отменяет предыдущие операции.
Повторить пошагово повторяет отмененные операции.

Параметры ноты вызывает диалог Свойства ноты.

Показывать тактовые черты включает режим показа тактовых черт.

Настройка цветов - вызывает диалог Настройка Цвета.


Редактор треков
Редактор треков состоит из строк, каждая из которых соответствует одному треку.

- Номер трека указан слева, в самом начале каждой строки.

- Кнопка, позволяющая выбрать цвет, котором будут отображаться все ноты данного трека.

- имя трека. Можно изменить по нажатию левой кнопки мыши.

- заглушить ноты данного трека.

- спрятать ноты данного трека.

- выделить ноты данного трека.

Контекстное меню

Выделить трек выделяет ноты данного трека.
Заглушить трек заглушает ноты данного трека.
Спрятать трек прячет ноты данного трека.

Стереть трек стирает все ноты данного трека.
Новый трек создает пустой трек.

Спрятать пустые треки прячет все строки редактора треков, которым соответствуют треки, не содержащие нот.


Карта нот
Карта нот – это инструмент, позволяющий видеть уменьшенное изображение всего произведения в целом – так же как оно отображается в области редактирования. На карте красным прямоугольником отображается область, видимая в данный момент в основном окне. Прямоугольник можно двигать с помощью мыши.

Карта нот выполнена в виде перемещаемого инструмента, она может быть прикреплена к верхней или нижней границе окна, либо оставлена в виде плавающего окна – в этом режиме карта становится полупрозрачной, что бы не загораживать спектрограмму в области редактирования.


Линейка
Линейка отображает время, отсчитываемое от начала произведения, или номер такта.

Контекстное меню линейки

Отметки времени переключает линейку в режим отображения времени. По умолчанию, линейка находится в этом режиме.
Отметки тактовых черт переключает линейку в режим отображения номеров тактов.

Вставить черту добавляет тактовую черту.
Стереть черту стирает тактовую черту.

Замечание: Только что распознанный файл не содержит тактовых черт, их расстановку можно произвести либо в ручном режиме с помощью пункта "вставить черту", либо при помощи инструмента Теппинг, позволяющего делать это на слух.


Инструменты

Редактировать включает инструмент "Редактирование". Этот инструмент позволяет визуально изменять длительность, положение и высоту ноты, а также использовать множественную селекцию.

При выбранном инструменте "Редактирование", для изменения длины ноты достаточно навести курсор на край ноты, после чего курсор изменится на горизонтальную стрелку, и, нажав левую клавишу мыши, двигать мышь горизонтально. При наведении курсора на середину ноты, нажатие на левую клавишу мыши приводит к захвату ноты, что позволяет передвигать ее, меняя как ее высоту так и время начала. Точно таким же образом можно перемещать и выделенную группу нот.

Стирать ноты включает инструмент "Стирать", который предназначен для стирания нот. Все ноты, над которыми проводится курсор с нажатой левой кнопкой мыши, удаляются.

Создавать ноты включает инструмент "Создавать новые ноты". При нажатии левой кнопки мыши над областью редактирования создается новая ноты. Аттрибуты создаваемой ноты можно изменить с помощью диалога Параметры нот по умолчанию.

Склеивать ноты включает опцию "склеивать". В этом режиме, если одна нота наложилась при редактировании на другую, то они склеиваются в одну ноту. Результирующей ноте приписывается громкость наиболее громкой из двух, прочие параметры берутся у той ноты, которую двигали.


Правка

Вырезать вырезает выделенные ноты.
Копировать копирует выделенные ноты.
Вставить вставляет содержимое буфера в начало отображаемой в окне редактирования области.

Отменить пошагово отменяет предыдущие операции.
Повторить пошагово повторяет отмененные операции.


Выделение

Выделить вызывает диалог Фильтр нот.
Первая выделенная нота в окне редактирования область, в которой находится первая выделенная нота.
Последняя выделенная нота показывает в окне редактирования область, в которой находится последняя выделенная нота.
Режим добавления к выделенному изменяет режим селекции. Если кнопка не нажата, то выделение следующей ноты снимает выделение с предыдущей. Если же она нажата – новые ноты будут добавляться к уже выделенным. Аналогичное действие имеет клавиша Shift.


Проигрывание

Проиграть экран запускает проигрывание всех видимых в основной области редактирования нот (при этом ноты сверху и снизу видимой области также играются).
Проиграть выделенное запускает проигрывание всех выделенных нот.
Проиграть все включает проигрывание всего произведения целиком.
Стоп останавливает проигрывание.

Режим проигрывания - позволяет выбрать один из следующих режимов проигрывания:
MIDI включает режим проигрывания "только MIDI".
Аудио включает режим проигрывания "только аудио".
Аудио + MIDI включает режим синхронного проигрывания MIDI и аудио.
MIDI замедленно включает режим замедленного проигрывания MIDI. Степень замедления проигрывания можно выставить в настройках редактора, по умолчанию, проигрывание происходит на половинной скорости.

Проигрывать в цикле включает режим циклического воспроизведения.


Вид

Увеличить увеличивает в два раза масштаб изображения в области редактирования.
Уменьшить уменьшает масштаб изображения в два раза.
Масштаб по умолчанию устанавливает масштаб в значение по умолчанию.

Показывать тактовые черты включает режим показа тактовых черт.


Дополнительные

Параметры ноты вызывает диалог Параметры ноты.
Параметры ноты по умолчанию вызывает диалог Параметры ноты по умолчанию.

Открыть соответствующую аудио-запись открывает связанный аудио-файл.

Создать файл MIDI создает отдельное окно с текущими MIDI-даными редактора.

Теппинг вызывает инструмент Теппинг.


Опции редактора TrueTone
Диалог Опции редактора TrueTone управляет различными особенностями поведения редактора TrueTone. Этот диалог вызывается с помощью пункта меню "Опции->Опции редактора TrueTone".

Диалог Опции редактора TrueTone состоит из трех закладок:

Закладка Основные - устанавливает параметры интерфейса и селекции.

Закладка Проигрывание - управляет настройками проигрывания.

Закладка Фокусировка - управляет особенностями фокусировки.

Кнопка OK подтверждает сделанные изменения, Отменить - отменяет их, Сбросить устанавливает параметры всех трех закладок в значения по умолчанию, Помощь вызывает контекстную справку.


Закладка Основные

Показывать
Крупные иконки регулирует размер иконок на кнопках панели инструментов.
Показать Карту Нот управляет появлением инструмента "карта нот".
Показывать тактовые черты включает отображение тактовых черт.
Отображать тактовые черты на линейке переключает отображение на верхней линейке на номера тактов. По умолчанию на ней отображается время.

Редактор треков
Показывать Редактор Треков управляет тем, будет ли по умолчанию показан редактор треков.
Спрятать пустые треки прячет строки редактора треков, соответствующие трекам без нот.

Выделение
Данный переключатель влияет на режим селекции – положение Добавить к выделенным приводит к тому что при выделении новых нот выделение со старых не снимается (аналогично действует клавиша Shift). Если же выбран пункт Заменить выделение то выделение новой ноты будет сопровождаться снятием выделения с предыдущей.


Закладка Проигрывание

Скорость замедленного проигрывания управляет тем, насколько (в процентах) будет замедленно проигрывание MIDI в режиме замедленного проигрывания.
Циклическое воспроизведение устанавливает режим закольцованного проигрывания.


Закладка Фокусировка

Отмена и Повтор
Фокусировать управляет тем, будет ли область редактирования показывать то место где при совершении этих операций произошли изменения.
Сфокусировать до операции заставляет редактор совершать операции в два шага. Сначала показывается область, с которой будут происходить изменения, а собственно операция выполняется при повторном нажатии на кнопку.

Где фокусироваться
Этот переключатель дает возможность управлять фокусировкой в том случае если выделенный фрагмент оказывается больше размера области отображения. положение Начало выделения заставляет редактор фокусироваться на первой ноте выделенной группы, а Середина выделения – на середине группы.

Различные настройки
Фокусироваться при Вырезании заставляет редактор переместить фокус в ту точку где производится вырезание.
Фокусироваться при множественном выделении управляет тем, будет ли редактор фокусироваться на выделенной группе нот.

Замечание: Фокусировка при выделении не происходит, если хотя бы одна из выделяемых нот и так видна в области редактирования.


Фильтр нот
Диалог Фильтр нот позволяет выделять ноты, удовлетворяющие определенным критериям. Параметр выбирается установкой соответствующего флага. Можно указывать один или более параметров выбора.

Фильтр нот вызывается нажатием кнопки [image] Выделить на панели инструментов Выделение либо с помощью пункта меню "Выделение->Выделение...".

Критерии

Левый столбец флагов заставляет учитывать при проверке следующие параметры:
Время устанавливает временной диапазон звучания нот.
Высота устанавливает диапазон по высоте тона.
Канал устанавливает MIDI каналы.
Громк. устанавливает громкость нот.
Длит. устанавливает длительность нот.
Трек устанавливает номер MIDI трека.
Инстр. устанавливает музыкальный инструмент.

Для всех параметров, кроме инструмента, справа указывается диапазон значений, удовлетворяющих заданному условию: в поле от указывается нижняя граница диапазона, в поле до - верхняя.
Флажок не позволяет инвертировать это условие – то есть такому условию будут удовлетворять все ноты кроме нот с параметром, находящимся в выбранном диапазоне.

Действие

Выделить позволяет выделить ноты удовлетворяющие условию, при этом предыдущее выделение сбрасывается.
Добавить добавляет к уже выделенным нотам те ноты, которые удовлетворяют условию.
Сузить дает возможность среди всех уже выделенных нот оставить только те, которые удовлетворяют заданным критериям.

Фокусироваться на выделенных нотах автоматически устанавливает видимую область на начало или конец селекции – в зависимости от установок диалога Опции редактора TrueTone.

Поле Установки позволяет сохранить установки фильтра для повторного использования. Файл установок диалога Фильтр нот имеет расширение .wnef. Подробнее об использовании файлов установок можно прочитать в разделе сохранение настроек.

Кнопка OK выделяет ноты в соответствии с установленными правилами, Отменить - закрывает диалог, Сбросить устанавливает все параметры в значения по умолчанию, Помощь вызывает контекстную справку.


Теппинг
Диалог Теппинг позволяет осуществлять расстановку тактовых черт на слух.
Диалог Теппинг вызывается нажатием кнопки [image] Теппинг на панели инструментов Дополнительные либо с помощью пункта меню "Инструменты->Теппинг".

Проигрывать
Аудио - при выборе этого пункта во время расстановки тактовых черт проигрывается исходный аудио-файл.
MIDI - при выборе этого пункта проигрывается результат распознавания.

Старт запускает проигрывание.
Стоп останавливает проигрывание.

Расстановка тактовых черт осуществляется с помощью пробела, либо соответствующей кнопкой Поставить черту в центре диалога. Проигрывание можно также запустить клавишей пробел.

Показывать текущую позицию включает указатель позиции проигрывания. Не используйте эту установку на медленных компьютерах.

Подробнее о расстановке тактовых черт можно прочитать в разделе тактовые черты.


Настройка цвета
Диалог Настройка цвета используется для настройки цветов рабочего пространства редактора TrueTone. Набор цветов отличается для обычного режима и режима "только MIDI".

Лежащий в основании окна спектр составляется из градиентов следующих трех цветов:
Фон - цвет подложки спектра или нулевого уровня.
Средняя точка спектра - цвет участков средней интенсивности.
Максимальная точка спектра - цвет участков наибольшей интенсивности.
Ноты - цвет прямоугольников, соответствующих нотам.
Выделенные ноты - цвет прямоугольников, соответствующих выделенным нотам.
Рамка выделения - цвет прямоугольника выделения.
Выделение - цвет заливки прямоугольника выделения.
Позиция проигрывания - цвет линии, показывающей место, проигрываемое в настоящий момент.
Тактовые черты - цвет которым отображаются тактовые черты.

В режиме "только MIDI" некоторые пункты отсутствуют, другие добавляются:
Заливка нот - цвет, заполняющий прямоугольники нот.
Заливка заглушенных нот - цвет, заполняющий заглушенные ноты.

Цветной квадрат справа показывает текущий цвет соответствующий выделенному пункту. Нажатие на цвет позволяет выбрать цвет из списка. Выберите пункт "Custom..." для вызова расширенного диалога выбора цвета.

Контраст - регулирует относительную яркость интенсивных и слабых участков спектра. При слишком высоком контрасте видны только самые громкие ноты, при слишком низком на экране появляется много несущественных деталей.

Раздел Установки позволяет сохранять цветовые схемы и экспортировать их в файл специального формата с расширением .wnec. Подробнее об использовании файлов установок можно прочитать в разделе сохранение установок.


Параметры ноты
Диалог параметры ноты устанавливает свойства конкретной ноты.

Время показывает абсолютное время начала ноты относительно начала композиции в секундах.
Нота отображает высоту ноты. WIDI работает в энгармонической шкале, используя соответствующие диезы вместо бемолей (например "C#" вместо "Db"). Замечание: Октавы WIDI соответствуют стандартным октавам в MIDI плюс 3.
Громк соответствует громкости соответствующей ноты в единицах MIDI.
Канал соответствует MIDI каналу который будет использован для проигрывания ноты. Только один инструмент может быть звучать на одном канале в одно и то же время, ноты одновременно играемые разными инструментами могут привести к нежелательному результату. 10-й канал как-правило отводится для ударных. Вообще не рекомендуется использовать более чем 16 каналов.
Длит, с - длительность ноты в секундах.
Трек - номер трека. Треки используются для группировки частей композиции без изменения их звучания.
Инструмент - инструмент используемый для проигрывания ноты.


Параметры нот по умолчанию
Диалог параметры нот по умолчанию определяет параметры по умолчанию, присваиваемые любой вновь создаваемой в редакторе TrueTone ноте.

Громк соответствует громкости ноты в единицах MIDI.
Канал соответствует MIDI-каналу который будет использован для проигрывания ноты. Только один инструмент может быть звучать на одном канале в одно и то же время, ноты одновременно играемые разными инструментами могут привести к нежелательному результату. 10-й канал как-правило отводится для ударных. Вообще не рекомендуется использовать более чем 16 каналов.
Длит, с - длительность ноты в секундах.
Трек - номер трека. Треки используются для группировки частей композиции без изменения их звучания.
Инструмент - инструмент используемый для проигрывания ноты.


Установить длину произведения
Диалог Изменить длину пьесы устанавливает длину пьесы.

Этот диалог может быть вызван с помощью пункта меню "Операции"->"Установить длину произведения...".

Длина содержит новое значение для длительности пьесы.

Замечание: При уменьшении длины пьесы часть нот может быть необратимо потеряна.


Команды меню
Для Вашего удобства здесь приведен полный список команд меню редактора TrueTone.

Правка
Вырезать - вырезать выделенные ноты.
Копировать - скопировать в буфер выделенные ноты.
Вставить - вставить содержимое буфера в начало экрана.

Отменить - отменить последнее действие. Число шагов отмены не ограничено.
Повторить - вернуть последнее отмененное действие.

Удалить - стереть выделенные ноты.
Заглушить или Озвучить - заглушить или озвучить выделенные ноты.
Транспонировать - транспонировать выделенные ноты.

Параметры ноты - вызвать диалог Параметры ноты для выделенных нот.
Параметры ноты по умолчанию - вызвать диалог Параметры нот по умолчанию.

Вид
Карта нот - показать Карту нот.
Редактор треков - показать Редактор треков.

Показывать тактовые черты - включает режим показа тактовых черт.
Показывать такты на линейке - переключает линейку между режимами отображения времени и тактовых черт.

Сделать видимыми все ноты - сделать видимыми все спрятанные ноты.

Увеличить - увеличить масштаб изображения в обоих направлениях.
Уменьшить - уменьшить масштаб изображения в обоих направлениях.
Масштаб по умолчанию - устанавливает масштаб изображения в значение по умолчанию.

Инструменты
Редактировать - использовать инструмент для редактирования.
Стирать ноты - использовать инструмент для стирания нот.
Создавать ноты - использовать инструмент для создания новых нот.

Теппинг - вызвать инструмент Теппинг для расстановки тактовых черт.

Режим склейки нот - включить режим склейки нот. В этом режиме пересекающиеся ноты склеиваются в одну.

Выделение
Выделить... - Вызвать диалог Фильтр нот в режиме выделения.
Добавить к выделению... - Вызвать диалог Фильтр нот в режиме добавки к выделению.
Удалить из выделения... - Вызвать диалог Фильтр нот в режиме удаления из выделения.

Показать начало выделения - Показать первую выделенную ноту.
Показать конец выделения - Показать последнюю выделенную ноту.

Режим добавления к выделению - добавлять новые ноты к уже выделенным (аналогично Shift).

Выделить все - выделить все ноты в произведении.
Инвертировать выделение - выделить все невыделенные ноты и снять выделение с выделенных.
Снять выделение - снять выделение со всех нот.

Проиграть
Проиграть все - проиграть все произведение.
Проиграть экран - проиграть всю видимую в области редактирования часть произведения.
Проиграть выделение - проиграть все выделенные ноты.
Остановить - остановить проигрывание.

MIDI - проигрывать только MIDI.
Аудио - проигрывать только исходный аудио-файл.
Аудио + MIDI - проигрывать синхронно MIDI и аудио.
MIDI замедленно - проигрывать MIDI в замедленном темпе.

Проигрывать в цикле - начинать проигрывание заново по достижении конца файла.
Операции
Создать MIDI файл - создает MIDI файл из текущего содержимого редактора.
Редактировать свойства MIDI - открыть диалог Свойства MIDI.

Установить длину пьесы - установить длину произведения. При уменьшении длины часть нот может быть потеряна.

Связать с аудио - указать аудио-файл, соответствующий содержимому редактора.
Открыть связанный аудио-файл - открыть в Аудио-окне связанный с содержимым редактора файл.

Опции
Опции редактора TrueTone - вызвать диалог Опции редактора TrueTone.
Настройка панели инструментов редактора - настроить панель инструментов редактора.
Настройка цветов редактора - вызвать диалог Настройка цвета редактора.


Команды клавиатуры
Для Вашего удобства здесь приведен список команд клавиатуры редактора TrueTone:

Редактор TrueTome

Ctrl+E - Включить режим редактирования.
Ctrl+D - Включить режим стирания.
Ctrl+N - Включить режим создания нот.
Ctrl+G - Включить режим склеивания нот.

= или серый + - Увеличить
- - Уменьшить
Num * - Установить масштаб по умолчанию.

Колесо Мыши - Промотать видимую область Влево/Вправо.
Shift+Колесо Мыши - Промотать видимую область Вверх/Вниз.
Home - Переместить видимую область в начало произведения.
End - Переместить видимую область в конец произведения.
PageUp - Переместить видимую область на один экран влево.
PageDown - Переместить видимую область на один экран вправо.

Shift+Главная кнопка мыши на ноте - Проиграть ноту.
Ctrl+Главная кнопка мыши на ноте - Заглушить или Озвучить выделенную ноту.
Вторая кнопка мыши на ноте - Параметры Ноты.

Del - Стереть выделенную ноту.
E - Редактировать выделенную ноту.
M - Заглушить или Озвучить выделенную ноту.

Ctrl+Z или Ctrl+BS - Отменить.

Ctrl+A - Вызывать диалог Атрибуты Нот По Умолчанию.

Пробел - Проиграть/Остановить проигрывание видимой части композиции.
Shift+Пробел - Проиграть в замедленном темпе.
Ctrl+Пробел - Проиграть одновременно с исходным звуком.
Alt+Ctrl+Пробел - Проиграть всю композицию.


Вопросы

Часто задаваемые вопросы
Инсталляция WIDI
Тестовая версия WIDI
Регистрация программы WIDI
Работа с WIDI
Настройка параметров
Техническая поддержка
Прочие вопросы

Инсталляция WIDI

Откуда я могу скачать дистрибутив WIDI?
Ответ: Пробную версию WIDI можно бесплатно скачать с нашего сайта со страницы http://www.widisoft.com/russian/download.html. Доступно несколько различных адресов с которых можно скачать WIDI, что позволяет Вам выбрать адрес с наибольшей скоростью закачки.

Чем отличаются WIDI Standard и WIDI Professional?
Ответ: В отличии от WIDI Standard, WIDI Professional содержит встроенный редактор TrueTone, специально предназначенный для коррекции возможных неточностей, возникающих в процессе автоматического распознавания.
Редактор TrueTone устроен по принципу клавишного редактора, и в качестве фона используется спектрограмма
исходного аудио-файла. Это позволяет визуально сравнивать результаты распознавания с оригиналом и корректировать их.

Необходимо ли мне скачать PAD файл?
Ответ: PAD файл содержит информацию о WIDI Recognition System и команде разработчиков. PAD файл (с расширением .xml) можно открыть при помощи специальных программ либо при помощи Internet Explorer версии 5.0 или выше.
За дополнительной информацией о формате PAD обращайтесь на сайт www.asp-shareware.org .
Если вы являетесь вебмастером каталога программ мы будем рады предоставить Вам информацию о нашей программе, для этого вы можете использовать PAD файл.

Как установить программу WIDI?
Ответ: Запустите файл widi32inr.exe и следуйте инструкциям программы установки.

Существуют ли версии на других языках кроме английского?
Ответ: В настоящее время существуют русскоязычная и англоязычная версии. В будущем возможен перевод WIDI и на
другие языки.

Тестовая версия WIDI

Могу ли я бесплатно использовать тестовую версию WIDI?
Ответ: Программа WIDI распространяется на условиях "try before buy". Вы можете бесплатно скачать и использовать тестовую версию в течении 14 дней. Незарегистрированная версия позволяет сохранять только 10 секунд мелодии в виде MIDI файла, но никаких других ограничений, в том числе встроенного счетчика времени использования тестовой версии, нет. Каждый раз при запуске незарегистрированной версии вы будете видеть диалог с предложением зарегистрировать WIDI. Запрещается продавать или модифицировать программу. Вы можете бесплатно распространять незарегистрированную версию при условии сохранения неизмененного дистрибутива. Более подробно условия использования программы изложены в лицензионном соглашении.

Какие ограничения содержатся в тестовой версии?
Ответ: Тестовая версия позволяет сохранять только 10 секунд MIDI файла. Каждый раз при запуске программы будет открываться диалог с предложением зарегистрировать WIDI. Вы можете бесплатно пользоваться программой WIDI в течении 14 дней. Если Вы хотите продолжать использовать программу по истечении этого срока вам необходимо зарегистрироваться.
Никаких других ограничений тестовая версия не содержит. Поддерживается работа с исходными файлами всех тех же форматов что и в зарегистрированной версии, нет ограничений на длину исходного файла или допустимых настроек алгоритма по сравнению с зарегистрированной версией.
Зарегистрированный пользователь имеет право на получение технической поддержки по электронной почте и имеет право на бесплатное получение регистрационного кода ко всем версиям WIDI выпущенным в течение полугода со дня регистрации. Для получения Вашего бесплатного ключа Вам необходимо обратится в службу технической поддержки. За более подробной информацией обращайтесь на страницу обновлениий: http://www.widisoft.com/russian/upgrade.html

В течении какого времени я могу пользоваться тестовой версией WIDI?
Ответ: Вы можете бесплатно пользоваться программой WIDI в течении 14 дней но счетчика времени бесплатного пользования программа не имеет. Если Вы хотите продолжать пользоваться программой WIDI по истечении этого срока или вы заинтересованы в дальнейшем развитии нашего проекта вам необходимо зарегистрироваться.

Где я могу найти примеры MIDI файлов создаваемых WIDI, не покупая лицензии?
Ответ: Незарегистрированная версия WIDI не позволяет сохранить полученную мелодию в виде MIDI файла целиком. Если Вы хотите посмотреть как выглядят типичный MIDI файл созданный WIDI, Вы можете скачать набор примеров со страницы примеров нашего сайта: http://www.widisoft.com/russian/samples.html. Там вы можете найти как полученные после распознавания MIDI файлы так и исходные звуковые файлы в формате mp3, а также соответствующие файлы установок распознавания. Чтобы посмотреть MIDI файл в виде нотной записи необходимо использовать редактор MIDI от стороннего производителя.

Могу ли я обращаться в службу поддержки, не являясь зарегистрированным пользователем?
Ответ: Зарегистрированные пользователи имеют приоритетное право на получение технической поддержки. Тем не менее мы готовы отвечать на Ваши вопросы по электронной почте даже если Вы не являетесь зарегистрированным пользователем. По общим вопросам связанным с программой WIDI обращайтесь на info@widisoft.com. Если у вас возникли вопросы в связи с конкретными проблемами в работе с WIDI пожалуйста, направляйте их на support@widisoft.com.
Пожалуйста, не посылайте в службу поддержки большие файлы. Все письма, объем которых превышает 50 килобайт, автоматически уничтожаются непосредственно на почтовом сервере. Мы не помогаем пользователям настраивать параметры распознавания для конкретных звуковых файлов.

Регистрация программы WIDI

Я приобрел лицензию WIDI. Где я могу получить свой регистрационный код?
Ответ: После того как вы зарегистрировались при помощи системы RegNow, Вам должен придти e-mail содержащий Ваш регистрационный код. При оплате по кредитной карте это происходит в течении нескольких минут. Если письмо не пришло, возможны две причины - либо Ваш платеж не был принят (например, Ваша кредитная карта не авторизована для интернет-платежей либо срок ее действия истек) либо вы ошиблись при написании Вашего e-mail адреса. При оплате по квитанции, подтверждение приходит после приема платежа. Если сообщение не пришло в течении дня, пожалуйста, обратитесь в службу поддержки WIDI по адресу support@widisoft.com.
Замечание: Пожалуйста, обратите внимание на правила обновления версий: http://www.widisoft.com/russian/upgrade.html.

Я ввел свой регистрационный код, но программа осталась незарегистрированной. В чем дело?
Ответ: Пожалуйста, попробуйте ввести код повторно. Используйте функцию "copy-paste", чтобы скопировать ключ и регистрационное имя из письма, полученного от RegNow. Убедитесь, что Вы не добавили излишних символов - особенно пробелов. После заполнения диалога регистрации перезапустите программу. Регистрация позволяет сохранять полученные MIDI файлы и убирает диалог с предложением зарегистрироваться. Чтобы убедиться, что вы правильно зарегистрировали WIDI, выберите пункт меню "Помощь"->"Ввести Ключ". В зарегистрированной версии появится табличка "Уже зарегистрирована". См также Введение регистрационного кода.

Я регистрировал более раннюю версию WIDI. Могу ли я бесплатно получить регистрационный код к текущей версии?
Ответ: В соответствии с лицензионным соглашением Вы можете бесплатно получить регистрационный код для всех версий выпущенных в течении полугода со дня регистрации. Для получения регистрационного кода пожалуйста, обращайтесь в службу технической поддержки по адресу support@widisoft.com.

Я зарегистрировал текущую версию WIDI. Могу ли я зарегистрировать будущие версии бесплатно?
Ответ: Да, вы можете зарегистрировать бесплатно все версии выпущенные в течении полугода со дня регистрации. Для получения регистрационного кода обращайтесь на support@widisoft.com. Мы не можем обещать что это правило останется неизменным для всех будущих версий, поэтому для уточнения обратитесь к лицензионному соглашению, поставляемому вместе с программой.

Я потерял свой регистрационный код. Как мне получить его повторно?
Ответ: Вам необходимо обратиться в службу технической поддержки по адресу support@widisoft.com с просьбой прислать копию регистрационного кода. Пожалуйста укажите в письме электронный адрес который Вы использовали при регистрации и Ваше имя пользователя или номер заказа. Это необходимо для идентификации Вашей регистрации.

Я зарегистрировал программу WIDI, и она мне не подошла. Могу ли я получить деньги обратно?
Ответ: Мы не возвращаем деньги. WIDI распространяется на условиях SHAREWARE, что означает возможность протестировать программу и решить, нужна ли она Вам, до того как платить за нее деньги. Условия продажи программы описаны в лицензионном соглашении, которое Вы можете найти в readme файле и в файле справки.

Работа с WIDI

Как использовать треки с аудио-дисков в качестве исходных файлов для распознавания?
Ответ: WIDI 3.0 умеет читать исходные файлы в различных форматах, в том числе и аудио треки компакт-дисков. Для чтения аудио трека используйте кнопку "Открыть". В появившемся диалоге выберите тип файла "файлы WAV, MP3 & CDA" и укажите CD дисковод в качестве директории для чтения. Выберите cda файл, соответствующий требуемому треку (cda файлы именуются Track**.cda, где ** номер трека. Так Track5.cda соответствует пятому аудиотреку диска) и нажмите OK.

Я ничего не слышу при проигрывании MIDI файлов, созданных при помощи WIDI. Как это исправить?
Ответ: Здесь возможно несколько различных ситуаций:
1) При проигрывании не слышно ни Wave ни MIDI, сначала проверьте слышно ли что-нибудь при проигрывании файлов стандартными средствами Windows (Media Player). Если не слышно ничего - проверьте настройки громкости (кнопка "Установки микшера" на панели инструментов WIDI). Также убедитесь, что колонки физически подключены к компьютеру и включены в сеть надлежащим образом.
Помните, что wave и midi каналы регулируются разными регуляторами.
2) Если Вы не слышите звука при проигрывании только MIDI файлов, но во всех программах, проверьте Control panel -> Multimedia -> закладка "MIDI". Попробуйте выбрать другое устройство проигрывания MIDI. Если это не помогло решить проблему, обратитесь к вашему поставщику оборудования.
3) Если звук не слышен только при проигрывании через WIDI, попробуйте выставить другие устройства в закладке "Устройства" в диалоге Опции в WIDI.
4) Если не слышно только MIDI. Откройте в WIDI заведомо не пустой MIDI файл (сначала попробуйте проиграть его в Media Player). Если ничего не слышно попробуйте выставить другие устройства в закладке "Устройства" в диалоге Опции в WIDI.
Если не слышно только те MIDI файлы, которые были созданны программой WIDI, проверьте установки в диалоге "Настройки распознавания". Откройте этот диалог и нажмите кнопку "По умолчанию". Также откройте Эквалайзер используя кнопку "Эквалайзер" и нажмите "На максимум". повторите распознавание предварительно закрыв GS окно. Если все еще ничего не слышно - попробуйте распознать другие файлы и CD-треки. Возможно, уровень звука в выбранном Вами файле слишком низок.

Какие файлы можно читать при помощи WIDI?
Ответ: WIDI 3.0 умеет читать исходные файлы в различных форматах. В их числе:
- Microsoft(R) PCM WAVE файлы любыми частотами дискретизации, 8 и 16 битные моно и стерео.
- Сжатые WAVE файлы всех форматов, для которых в вашей системе установлен ACM декодер. Обычно в их число входят ADPCM, A-Law, u-Law форматы и другие. Полный список поддерживаемых Вашей системой типов компрессии звука можно посмотреть в Control Panel -> Multimedia -> Advanced -> Audio Compression Codecs.
- Аудио файлы, сжатые по методу MPEG с расширениями *.mp1, *.mp2, *.mp3 and *.mpp. Эти файлы могут быть прочитаны, даже если в вашей системе не установлено специального кодека.
- CD-треки аудио дисков. Вы можете открыть аудио трек так же как и обычный аудио файл без предварительного переписывания на жесткий диск. Внимание: эта функция может не поддерживаться старыми CD-ROM дисководами. См. подробнее на странице Чтение дисков CD-аудио.
- GS файлы созданный WIDI. См. подробнее Использование GS-файлов.
- MIDI файлы.
-.wne - файлы редактора TrueTone.
-.wset - файлы установок распознавания.
-.wnef - файлы установок Фильтра Нот редактора TrueTone.
-.wnec файлы установок цветовой схемы редактора TrueTone.

Что такое GS файлы?
Ответ: Алгоритм распознавания, используемый в WIDI, состоит из двух частей. Первая, называемая "Звук->Тон" занимает много времени и дает на выходе спектральные данные. После этого быстрый алгоритм "Тон->MIDI" конвертирует спектральные данные в ноты. GS файл - это файл, содержащий спектральные данные. В нем сохраняется промежуточная информация, что позволяет однократно, вычислив его в дальнейшем генерировать MIDI файлы с разными установками закладки "Тон->MIDI" и эквалайзера. Параметры, управляющие созданием GS, находятся на закладке "Звук->Тон" диалога "Настройки распознавания". Эти параметры не влияют на результат, когда вы распознаете GS-файл.

Что делает функция синхронного проигрывания и как ей пользоваться?
Ответ: Синхронное проигрывание позволяет одновременно проигрывать исходный аудио-файл и полученный в результате распознавания MIDI. Функция синхронного проигрования доступна как в окне MIDI так и в редакторе TrueTone. Синхронное проигрывание позволяет сравнить на слух результаты распознавания и исходный файл с тем, чтобы уточнить дальнейшее изменение настроек. Может понадобится вручную связать текущий MIDI-файл с соответствующим аудио-файлом, если WIDI не удается сделать это автоматически.
Замечание: Если Вы свяжете MIDI-файл, с несоответствующим ему аудио-фрагментом, то нажатие кнопки "Синхронное проигрывание" приведет к тому, что две несвязанные мелодии будут проигрываться одновременно. Это не запрещено, но представляется бессмысленным.

Как распечатать ноты?
Ответ: к сожалению, WIDI не имеет соответствующей функции. Используйте для этого сторонний редактор MIDI.

Настройка параметров

Чему соответствует количество треков создаваемых WIDI в MIDI файле?
Ответ: MIDI файл создаваемый WIDI может содержать до 18 голосов. Число голосов регулируется параметром "Полифония" находящимся на странице "Тон->MIDI" диалога "Настройки распознавания". Здесь полифония означает максимальное число нот звучащих одновременно. Голоса разделяются по громкости. В итоговом MIDI файле для каждого момента времени число одновременно звучащих нот не превосходит значение параметра "Полифония" причем отбираются наиболее громкие, а все остальные игнорируются. Число треков не равно значению параметра "Полифония". WIDI пока не умеет распознавать число голосов и инструменты, которыми они исполняются. Замечание: В WIDI 3.0 также добавилась возможность разместить все ноты на одном треке вне зависимости от их громкости.

При каких условиях необходимо изменять установки WIDI выставленные по умолчанию?
Ответ: Основным критерием качества распознавания считается сходство на слух исходного звукового файлв и созданного WIDI MIDI файла. То есть установки по умолчанию нуждаются в коррекции, в случае если Вы слышите существенное различие исходного и созданного файлов. Типичными ошибками распознавания являются: наличие лишних, отсутствующих в исходной записи нот или наоборот, потеря существенных для мелодии нот. Также часто встречаются ситуации, когда в итоговом файле каждая нота разбивается на пару синхронно звучащих нот с интервалом в октаву, также часто к распознанной мелодии добавляются случайные короткие высокие ноты.
Вы можете воспользоваться установками распознавания поставляемые вместе с программой а также доступными на нашем сайте на http://www.widisoft.com/russian/presets.html.

Как использовать эквалайзер?
Ответ: Эквалайзер позволяет выставлять относительные громкости для нот разных высот. Он состоит из набора регуляторов с изображенной под ними фортепьянной клавиатурой. Нажимая левую кнопку мыши на области соответствующей регуляторам можно подстраивать громкость соответствующей ноты. Эквалайзер позволяет распознавать ноты только из определенного частотного диапазона или убрать из получаемого файла определенную частоту. Например, распознавая мелодию, в которой мелодия на высоких частотах сопровождается басовой партией. Вы можете распознать только мелодию, установив все басовые регуляторы Эквалайзера на нуль.

Техническая поддержка

Каким образом я могу получить техническую поддержку?
Ответ: По электронной почте. Пожалуйста, обращайтесь support@widisoft.com на или на страницу технической поддержки http://www.widisoft.com/russian/support.html. См. также Способы получения технической поддержки.

У меня не получается самому настроить WIDI таким образом, чтобы качество распознавания меня устраивало. Могу ли я выслать исходный звуковой файл службе поддержки?
Ответ: Служба технической поддержки WIDI не принимает письма с прикрепленными файлами. Если Вы не можете самостоятельно подобрать установки для распознавания какой-либо мелодии Вы можете обратиться к нам за помощью, но к сожалению мы не можем гарантировать что у нас будет такая возможность. Решение в каждом случае принимается индивидуально.

Прочие вопросы

Могу ли я использовать WIDI как компонент собственной программы?
Ответ: Да, можете, но распространять такой продукт запрещено. Программный продукт содержащий в качестве компонента WIDI любой версии может использоваться Вами только для персональных нужд.
Если у вас есть какие-либо предложения о сотрудничестве, пожалуйста, обращайтесь на info@widisoft.com.

Где я могу найти более ранние версии WIDI?
Ответ: Нет никакой необходимости искать более ранние версии. Единственное исключение составляет случай, когда Вы являетесь зарегистрированным пользователем более ранней версии нежели текущая и потеряли дистрибутив. В этом случае пожалуйста обратитесь в службу технической поддержки.
Если Вы обнаружите дистрибутивы программы WIDI более старых версий где-либо в интернете, пожалуйста, сообщите нам на info@widisoft.com.


Чтение дисков CD-аудио
Начиная с версии 3.2 WIDI должна корректно работать со всеми моделями приводов CD-ROM.


Способы получения технической поддержки
Техническую поддержку можно получить несколькими способами.

Страница технической поддержки на сайте:
http://www.widisoft.com/russian/support.html

Помощь на сайте
http://www.widisoft.com/webhelp_rus/index.html

Вопросы на сайте (Часто задаваемые вопросы)
http://www.widisoft.com/russian/faq.html

У Вас есть вопросы, предложения, идеи, сообщения об ошибках? Пишите нам:

Форум пользователей
http://www.widisoft.com/forum

Поддержка по е-мейл
support@widisoft.com

Дополнительная информация находится на страницах:

Примеры работы:
http://www.widisoft.com/russian/samples.html

Страница установок распознавания:
http://www.widisoft.com/russian/presets.html


Как зарегистрировать WIDI
Вы можете скачать тестовую версия программы WIDI Recognition System с нашего сайта бесплатно. Ознакомительная версия позволяет сохранять только 10 секунд файла MIDI и при каждом запуске отображает стартовый диалог с предложением зарегистрироваться. Допускается бесплатное использование тестовой версии в течении 14 дней. Прочтите Лицензионное соглашение для получения детальной информации.

Чтобы посмотреть примеры результатов работы WIDI посетите страницу примеров: http://www.widisoft.com/russian/samples.html.

Для того чтобы превратить тестовую копию WIDI Recognition System в полнофункциональную, необходимо ее зарегистрировать. Помимо снятия ограничений на функциональность программы, регистрация дает право на получение технической поддержки по e-mail.

Мы предполагаем, что перед покупкой программы пользователь внимательно протестирует ее, и только после этого примет окончательное решение об оплате. Факт покупки программы одновременно означает, что пользователь удовлетворен возможностями и качеством программы. Поэтому мы не осуществляем возврат денег и не принимаем претензии по качеству работы программы.

Покупка программы в России и СНГ осуществляется через наших партнеров - компанию SoftKey. Для оплаты Вы можете использовать кредитную карту, банковский перевод (в том числе через Сбербанк), Яндекс Деньги и другие способы по Вашему выбору. Вы можете также выбрать валюту платежа. Сумма платежа может изменяться в зависимости от выбранного метода оплаты.

Вы можете также заказать компакт-диск с программой WIDI Recognition System. Не забудьте указать эту опцию при покупке, иначе Вы получите только регистрационный ключ по электронной почте.

Посетите страницу регистрации http://www.widisoft.com/russian/order.html?ref=help для получения детальной информации.


Введение регистрационного кода
Регистрационный ключ присылается по электронной почте. Он состоит из двух строк - регистрационного имени и собственно кода. Выглядит это примерно так:

Регистрационное Имя: John Smith
Регистрационный Код: 56g5-3w43545bjweojlzFtSeklf7xFb7MU4

(Замечание: Это не настоящий регистрационный код, формат кода также может быть иным.)

Вам необходимо скопировать регистрационный код в WIDI. Запустите программу, нажмите кнопку "Ввести Код". Используя функцию "copy-paste" скопируйте Ваш регистрационный ключ и имя, они должны быть в точности такими же как в письме. Убедитесь также, что Вы случайно не добавили пробелов до или после регистрационного ключа или имени:

После введения регистрационного имени и ключа перезапустите программу. Регистрация отключает ограничение на длину сохраняемых MIDI-файлов и убирает стартовый диалог. Чтобы убедится в успешной регистрации, выберите пункт меню "Помощь->Ввести Ключ" после перезапуска. В зарегистрированной версии появится сообщение "Уже зарегистрирована".


Информация об обновлениях
Мы гарантируем бесплатность обновлений в течении 6-месячного периода после регистрации или до выпуска следующей версии, если в течении этого периода версий не выпускалось. Также мы, как правило, предоставляем скидки зарегистрированным пользователям более старых версий WIDI.

Обновления к WIDI 3.2:

· Все зарегистрированные пользователи WIDI 3.0 могут получить бесплатный ключ к WIDI 3.2. Для получения обратитесь по адресу newkey@widisoft.com.
· Зарегистрированные пользователи более старых версий WIDI могут получить скидку при покупке WIDI 3.2 Standard.
· Зарегистрированные пользователи WIDI 3.2 Standard могут получить скидку при покупке WIDI 3.2 Professional.

За более детальной информацией обращайтесь на http://www.widisoft.com/russian/upgrade.html.


Лицензионное соглашение
Лицензионное Соглашение

ПЕРЕД ИСПОЛЬЗОВАНИЕМ ПРОГРАММЫ ВНИМАТЕЛЬНО ПРОЧТИТЕ ВСЕ УСЛОВИЯ
ДАННОГО СОГЛАШЕНИЯ. ИСПОЛЬЗОВАНИЕ ПРОГРАММЫ ОЗНАЧАЕТ ВАШЕ СОГЛАСИЕ
С УСЛОВИЯМИ ДАННОГО СОГЛАШЕНИЯ. ЕСЛИ ВЫ НЕ СОГЛАСНЫ С УСЛОВИЯМИ
СОГЛАШЕНИЯ, НЕ ИСПОЛЬЗУЙТЕ ПРОГРАММУ.

Все имущественные права на программу WIDI Recognition System (в дальнейшем
именуемую "Программа") принадлежат компании WIDISOFT (в дальнейшем
- WIDISOFT). WIDISOFT разрешает использование Программы при
условии Вашего согласия со следующими положениями.

Вы можете свободно распространять незарегистрированную тестовую
версию Программы, соблюдая целостность и неизменность
дистрибутива. Вы не имеете права предпринимать обратное
конструирование, декомпиляцию или дизассемблирование Программы или
использовать любой другой метод для преобразования в форму,
воспринимаемую человеком а также разрешать кому-либо делать это.

Предполагается, что Вы полностью оцените работу и функциональность
Программы за 14-дневный тестовый период до совершения покупки.
Данный принцип "попробуй перед покупкой" обеспечивает надлежащую
проверку на соответствие Вашим требованием. Поэтому Вы
соглашаетесь с тем, что возврат денег после совершения покупки не
предусмотрен.

Если Вы являетесь зарегистрированным пользователем, Вы можете
использовать программу для собственных нужд. Запрещается
давать в прокат или во временное пользование как Программу так и
Вашу персональную регистрационную информацию кому-либо без письменного
разрешения WIDISOFT. Вы можете одновременно использовать только одну
копию Программы. Запрещается использование программы в сетях или более
чем на одной машине без соответствующей лицензии. Вы имеете право
полностью уступить право пользования Программой другому лицу, при этом
вы теряете право пользования Программой.

Лицензия и право использования Программы не включает право на использование,
кодирование или любое другое изменение обрабатываемых Программой данных для
продажи, публикации, а также распространения на любых носителях, в
сетях общего пользования и широковещательных сетях.

РАСПРОСТРАНЯЕТСЯ НА УСЛОВИЯХ "КАК ЕСТЬ". WIDISOFT НЕ БЕРЕТ НА СЕБЯ
И НЕ ПОДРАЗУМЕВАЕТ КАКИХ-ЛИБО ГАРАНТИЙНЫХ ОБЯЗАТЕЛЬСТВ. WIDISOFT
НЕ ОБЯЗУЕТСЯ ОБЕСПЕЧИВАТЬ ОБНОВЛЕНИЯ И ТЕХНИЧЕСКУЮ ПОДДЕРЖКУ
ПРОГРАММЫ. ВЫ ИСПОЛЬЗУЕТЕ ПРОГРАММУ НА СВОЙ РИСК. WIDISOFT НЕ
БЕРЕТ НА СЕБЯ ОТВЕТСТВЕННОСТЬ ЗА ПОТЕРЮ ДАННЫХ, УЩЕРБ, ПОТЕРЮ
ПРИБЫЛИ ИЛИ ЛЮБЫЕ ДРУГИЕ ПОТЕРИ, ПРОИЗОШЕДШИЕ ВО ВРЕМЯ
ИСПОЛЬЗОВАНИЯ ИЛИ НЕПРАВИЛЬНОГО ИСПОЛЬЗОВАНИЯ ДАННОГО ПРОГРАММНОГО
ОБЕСПЕЧЕНИЯ.


О компании WIDISOFT
Первая версия WIDI называлась "Music Recognition 1.8", и была выпущена в 1998 году. Исходно это было консольное приложение для DOS. Отсутствовало проигрывание файлов, Эквалайзер и многое другое. Годом позже была выпущена версия 2.0, снабженная интерфейсом Windows и Эквалайзером.

Постепенно, шаг за шагом, программа развивалась, добавлялись новые возможности. Версия 2.7 выпущенная в 2001 году имела развитый справочный файл, многочисленные возможности подстройки параметров распознавания, функцией синхронного проигрывания, многооконным интерфейсом и многим другим.

В настоящее время WIDISOFT является лидирующим разработчиком технологий распознавания музыки. Мы активно осуществляем как дальнейшие исследования в сфере распознавания музыки так и развитие пользовательских характеристик программы, а также расширением спектра выпускаемых продуктов.

WIDI является открытым проектом. Если Вы обладаете познаниями в области цифровой обработки сигналов, программировании по Windows, написании технических текстов, переводе на другие языки или у Вас есть идеи относительно распознавания музыки - обращайтесь к нам.

WIDISOFT располагается в Москве. В России и СНГ продажи WIDI осуществляет фирма SoftKey.


Контактная информация
Для получения технической поддержки, см страницу Способы получения технической поддержки или страницу технической поддержки http://www.widisoft.com/russian/support.html.

Основной контактный е-мейл:
info@widisoft.com

Веб-сайт компании:
http://www.widisoft.com

Обращайтесь.


Благодарности
Команда разработчиков WIDI благодарит следующих разработчиков за создание полезных бесплатных программ, используемых в нашем проекте:

Fedor Kozhevnikov, Igor Pavluk, Serge Korolev fkozh@iname.com | RX Library (http://www.rxlib.com)
Polaris Software | Patch for RX Library (http://polesoft.da.ru)
Markus F.X.J. Oberhumer, Laszlo Molnar markus.oberhumer@jk.uni-linz.ac.at | UPX EXE-packer ( http://upx.sourceforge.net)
NullSoft Inc. | Nullsoft Scriptable Installation System (http://www.nullsoft.com/free/nsis)

Эта программа также использует Audio File Library, Copyright (C) 1998-2000, Michael Pruett michael@68k.org, лицензированную на основании LGPL.

Спасибо за ваши усилия.


.topic 10000
Основная задача программы WIDI это распознавание музыки. Музыкальная запись может быть представлена в двух различных формах: звуковая волна и нотная запись. Звуковая волна - это запись зависимости звукового давления от времени. Примерами могут служить файлы формата .wav и .mp3, магнитофонные записи и так далее. В таком виде, проигрываемый звук в точности совпадает с тем, который был записан. Тем не менее, в этом случае, многие инструменты и звуки, которые звучат одновременно, перекрываются. Это делает невозможным внесение в музыкальное произведение таких изменений как изменение нот, аранжировки и т.д. Нотная запись - например, обычная партитура или файл формата MIDI, по сути являются набором команд, какую ноту каким инструментом следует сыграть. Такая форма записи легко поддается редактированию и занимает меньше места, чем файлы .wav. Однако, не любой звук может быть записан в такой форме. Например, человеческую речь записать в виде нотной записи невозможно.

Задача распознавания, в особенности распознавания музыкальных записей, является серьезной математической проблемой, и не имеет в настоящее время универсального решения. Тем не менее, WIDI Recognition System включает в себя алгоритмы, которые позволяют осуществлять распознавание полифонических записей с достаточно высокой точностью. Более того, значительное число настраиваемых параметров позволяют распознавать различные музыкальные стили, инструменты и так далее.

WIDI является уникальной многофункциональной системой, включающей в себя функции записи и отображения звуковой волны, специализированный редактор нот (только версия Professional), который позволяет осуществлять визуальное сравнение спектрограммы исходной волны и нот, полученных в процессе распознавания.

WIDI умеет читать исходные файлы в таких форматах, как некомпрессированный wav, mp3, CD треки и даже звук, непосредственно поступающий с микрофона, без предварительной записи в файл (распознавание в реальном времени).

WIDI позволяет, имея только звуковую волну, распознать ее и после этого:

 Изменять аранжировку, высотный диапазон и тональность
 Создавать предварительный просмотр для файлов mp3 в коллекциях
 Загружать любимые мелодии в мобильный телефон
 Получать нотные записи музыкальных композиций для самостоятельного исполнения

(Для редактирования нот и загрузки мелодий в мобильный телефон вам может понадобится стороннее программное обеспечение)

.topic 10250
Основная задача программы WIDI это преобразование оцифрованных музыкальных полифонических записей в файлы MIDI и распознавание музыки в реальном времени.

Исходные данные
Полифонические и монофонические записи в форматах MP3, WAVE, и аудио CD-треки.
Звук поступающий с микрофона в реальном времени.
Поддерживаются также сжатые файлы WAVE.
Некоторые другие форматы (AIFF/AIFF-C, NeXT/Sun .snd/.au, Berkeley/IRCAM/CARL Sound File) поддерживаются с помощью библиотеки Audio File.

Основные особенности распознавания
Возможность выбрать один из нескольких алгоритмов, в том числе специально предназначенных для монофонического распознавания.
Алгоритм распознавания автоматически подстраивается под тональность произведения.
Простая гармоническая модель позволяет автоматически исключать ошибочные ноты.
Многочисленные настройки распознавания позволят достигнуть наивысшего качества распознавания.
Установки распознавания могут быть сохранены в файл для повторного использования.
Созданы  наборы установок распознавания для некоторых типичных случаев.
Существует возможность выбрать частотный диапазон в котором будет производится распознавание.
Возможность распознавания отдельных каналов стерео-записи и их комбинаций.

Возможности редактирования
Возможно выделить для распознавания любую часть музыкальной записи.
Использование редактора TrueTone (tm), включенного в версию Professional, позволяет эффективно повысить качество распознавания. Редактор позволяет значительно улучшить читаемость нотной записи, благодаря возможности расставлять тактовые черты, не изменяя звучания.

Работа в реальном времени
Вы можете распознавать ноты "на лету", управляя MIDI-синтезатором непосредственно из модуля распознавания в реальном времени.

Представление результата
На выходе получается многоканальный, отсортированный по громкости файл MIDI.
Есть возможность выбрать один из большего списка инструментов, чтобы использовать его в результирующем файле MIDI.

Дополнительные возможности
Возможно записывать звук с микрофона или с любого другого входа, используя встроенный звукозаписывающий модуль.
Встроенный эквалайзер позволяет настраивать относительную громкость нот различной высоты.
Возможно проиграть файлы всех поддерживаемых форматов.

.topic 10100
По умолчанию при запуске WIDI в первую очередь запускается Мастер распознавания. Используя Мастер распознавания вы можете получить первые результаты распознавания уже через пару минут, и заодно познакомится с программой. Заглавная страница мастера выглядит следующим образом:

Распознать уже существующий mp3, Wave или CD - дает возможность указать для распознавания mp3, Wave файл или CD-трек.
Записать аудио и распознать его - дает возможность записать аудио используя встроенный звукозаписывающий модуль и распознать его.
Распознавание в реальном времени - включает модуль распознавания в реальном времени.
Показать страницу быстрого старта - открывает файл помощи на странице Быстрый старт.
Закрыть Мастер распознавания - закрывает мастер распознавания.

Показывать Мастер при старте программы - если этот флажок поставлен, то при старте программы в первую очередь запустится Мастер распознавания.

Выберете интересующий вас пункт и нажмите кнопку Далее.

Распознавание уже существующего аудио-файла

Воспользовавшись кнопкой Поиск укажите местоположение искомого фала, после чего нажмите Далее.
Используя кнопку Параметры, установите параметры распознавания вручную, либо выберите из списка одну из существующих предустановок. Кнопка Импорт позволит указать любой файл установок распознавания.
После этого Мастер предлагает открыть результат распознавания в редакторе TrueTone (только WIDI Professional).

Запись аудио и распознавание

Кнопка Далее запускает модуль записи звука.
Используя кнопку Параметры, установите параметры распознавания вручную, либо выберите из списка одну из существующих предустановок. Кнопка Импорт позволит указать любой файл установок распознавания.
После этого Мастер предлагает открыть результат распознавания в редакторе TrueTone (только WIDI Professional).

Распознавание в реальном времени

Кнопка Далее запускает модуль распознавания в реальном времени.

.topic 10200
Несколько простых операций можно проделать, для начала, не углубляясь в изучение WIDI.

При первом знакомстве с программой, рекомендуется воспользоваться Мастером распознавания.

Распознавание предварительно записанных файлов
Выберите требуемый файл (Нажмите   Открыть).
Нажмите   Распознать и дождитесь, пока процесс распознавания завершится.
Теперь результат распознавания можно прослушать (нажмите   Проиграть).
Если Вы используете зарегистрированную версию, сохраните файл (нажмите   Сохранить).

Распознавание в реальном времени
Запустите модуль распознавания в реальном времени (нажмите   В реальном времени).
Пойте или играйте на музыкальном инструменте в микрофон.
Запустите Микшер Windows (нажмите   Микшер Windows).
Установите источник звука и уровень записи. Указатель уровня при этом отражает поступающий сигнал. При необходимости, обратитесь к документации Windows.
Ноты MIDI должны звучать сразу как только вы их поете или играете.
Запустите запись нажав кнопку   Запись.
Записанный материал становится доступным после нажатия кнопки Готово.
Теперь вы можете прослушать результат (нажмите кнопку   Проиграть на окне MIDI).
Сохраните файл (нажмите   Сохранить). Ознакомительная версия программы позволяет сохранять в файл до 10 секунд MIDI.

Используя версию Professional вы можете также редактировать результат распознавания с помощью редактора TrueTone (tm).

Чтобы улучшить качество распознавания и воспользоваться другими функциями WIDI обратитесь к следующим разделам:
Использование WIDI
Дополнительные темы

.topic 10630
Основное окно лежит в основании всех остальных окон WIDI и служит рабочим пространством для всех модулей WIDI. Оно так же содержит быстрые вызовы функций, которые либо универсальны, либо общие для многих дочерних окон WIDI. В Обзоре меню содержится полный список команд меню.

Большинство функций WIDI доступно из панели инструментов:
  кнопка Открыть открывает новый файл. В появившемся диалоге выберите соответствующий фильтр из списка, чтобы открыть файлы различного типа.
  Закрыть закрывает окно, активное в данный момент.
  Сохранить сохраняет активный файл. Замечание: Эта функция в незарегистрированной версии всегда отключена.
  Запись вызывает модуль Записи звука, при помощи которого можно записать новый звуковой файл.
  В реальном времени открывает модуль Распознавания в реальном времени.
  Опции открывает диалог Опции, позволяющий изменять установки программы.
  Настройки открывает диалог Настройки распознавания, где вы можете установить параметры распознавания.
  Эквалайзер вызывает Эквалайзер, задача которого - отфильтровывать нежелательные частотные диапазоны во время процесса распознавания.
  Микшер Windows вызывает стандартный Микшер Windows.
  Расположить размещает все дочерние окна специальным образом.

Уменьшенное изображение  в статусной строке служит для напоминания о текущих установках Эквалайзера и может быть использовано для его вызова.

.topic 10650
Окно аудио отображает аудио (Wave, MP3, аудио-CD и других форматов) в виде звуковой волны. Окно аудио открывается при загрузке аудио записи с диска или после записи звука с помощью модуля записи.  Может быть открыто только одно Окно аудио.

  Проиграть Все проигрывает всю запись целиком.
  Проиграть выделенное проигрывает выделенный фрагмент.
  Пауза приостанавливает проигрывание.
  Стоп останавливает проигрывание.
  Распознать запускает распознавание выделенного фрагмента.
  Выделить от начала помещает начало выделения на начало записи.
  Выделить до конца помещает конец выделения на конец записи.
  Левый канал выбирает для распознавания левый канал стерео-записи.
  Правый канал выбирает для распознавания правый канал стерео-записи.
  Сумма каналов  выбирает для распознавания сумму левого и правого каналов стерео-записи. Этот вариант использовался предыдущими версиями WIDI.
  Разность каналов  выбирает для распознавания разность левого и правого каналов стерео-записи, что может быть для удаления основного голоса с целью изготовления записей для караоке.
Регуляторы выделения   и    показывают время начала и конца выделения.
  Длительность также работает как кнопка "Выделить все".

Выделение фрагмента записи - нажмите основную кнопку мыши над изображением волны, двигайте мышь, отпустите кнопку для завершения выделения.

Замечание: WIDI сохраняет все аудио-файлы в формате 16 бит Моно или Стерео 22050 Гц. Будьте внимательны, чтобы не перезаписать исходный файл.

.topic 10660
Окно MIDI соответствует MIDI-композиции (расположенной в памяти или на диске). Оно также используется как простой Проигрыватель MIDI. Окно MIDI автоматически появляется после завершения процесса распознавания или после редактирования данных с помощью редактора TrueTone. Также Вы можете открыть MIDI-файл с диска.

  Проиграть проигрывает композицию.
  Пауза приостанавливает проигрывание.
  Стоп останавливает проигрывание.
  Проиграть синхронно проигрывает MIDI-композицию одновременно с исходным файлом, или, если идентифицировать источник не удается - одновременно с открытой в настоящее время аудио-записью.
  Транспонировать позволяет транспонировать всю MIDI-композицию на произвольное число полутонов.
  Установить инструмент позволяет указать инструмент которым следует проигрывать MIDI-композицию.
  Вызвать редактор TrueTone вызывает редактор TrueTone для текущей MIDI-композиции. Данные MIDI копируются в редактор и редактирование не влияет на содержимое Окна MIDI. Если соответствующие спектральные данные не обнаружены, Редактор TrueTone запускается в режиме "только MIDI". Эта кнопка недоступна в WIDI Standard.
  Свойства MIDI открывает диалог Свойства MIDI-файла для текущей композиции.

Замечание: Если Вы планируете редактировать композицию с помощью редактора TrueTone позже, следует открыть редактор после распознавания и сохранить результаты в виде "Файла Редактора TrueTone".

.topic 10673
Окно GS содержит GS-файл, предназначенный для необязательного промежуточного шага распознавания и используемый для ускорения повторного распознавания.

Кнопка   Распознать запускает последний этап процесса распознавания и выдает MIDI-файл. Двойной щелчок по изображению спектра также запускает его распознавание.

.topic 10674
Модуль Запись Звука представляет из себя простейшую звукозаписывающую программу. В разделе Запись Звука находится список возможностей и рекомендации по использованию.
Модуль Записи Звука можно вызвать выбрав пункт меню "Файл->Запись Звука" или нажав на кнопку   Запись звука на панели инструментов основного окна.

Кнопка   Подготовить подготавливает диск для немедленной записи. Если Вы не используете временные файлы (см Установка Опций), программа спросит у Вас имя файла. Используйте эту кнопку если Вы не хотите никаких задержек после нажатия кнопки Запись.
Кнопка   Запись начинает запись. Если Вы не используете временные файлы (см Установка Опций), программа спросит у Вас имя файла.
  Пауза приостанавливает запись до тех пор пока Вы не нажмете кнопку Запись для возобновления. После возобновления запись продолжится с текущей позиции.
  Стоп останавливает запись.
  Микшер Windows - вызывает стандартный Микшер Windows для подстройки уровня записи.
Отсчетов в сек. - выберите из списка частоту дискретизации будущего файла.
Разрешение - Вы можете установить число бит на один отсчет с помощью переключателя.
Каналы - выберите, монофонический или стереофонический файл будет записываться.
Указатель уровня позволяет Вам отслеживать уровень звука в процессе записи для подстройки уровня записи.
флажок Уровень включает и выключает Указатель уровня. Как правило, другие приложения не могут записывать звук пока этот выключатель включен.
Кнопка Помощь открывает эту страницу файла помощи.
Кнопка Готово закрывает модуль записи звука и загружает записанный звук в Окно Аудио.
Отмена не загружает записанный звук в WIDI. Если запись производилась во временный файл, она стирается.

Замечание: Если вы собираетесь использовать записанный файл только в текущей версии WIDI, Вам нет необходимости устанавливать качество записи выше чем 16 бит стерео 22050 Гц.

.topic 40000
Модуль распознавания в реальном времени позволяет производить запись как с микрофона так и с любого другого входа, выбранного в пункте источник звука и одновременно осуществлять преобразование звука в формат MIDI в соответствии с текущими установками распознавания.
Модуль распознавания в реальном времени вызывается кнопкой   В реальном времени панели инструментов основного окна.

  Запись MIDI запускает запись распознанных MIDI нот.
  Авто-запись начинает запись MIDI как только появляется первая нота.
  Стоп останавливает запись. Повторное нажатие кнопки Запись MIDI приведет к потере предыдущей записи и начале новой.

  Опции - Вызывает диалог Опции и позволяет выбрать Устройство ввода аудио.
Кнопка   Установки позволяет установить Установки распознавания в реальном времени и атрибуты MIDI-файла.
  Эквалайзер вызывает окно Эквалайзера. Установки Эквалайзера срабатывают немедленно, вам нет необходимости закрывать окно для этого.
  Микшер Windows - позволяет вам настроить системный Микшер.

Также доступны следующие опции и установки:

Флажок Распознавать включает распознавание поступающего звука.
Флажок Играть ноты включает непосредственное проигрывание распознанных нот.
Индикатор Записанные данные - показывает длительность записанной MIDI-последовательности.

Кнопка Алгоритм позволяет выбрать один из нескольких алгоритмов распознавания. Выбранный алгоритм имеет дополнительные настройки.
Ползунок Полифония появляется при выборе алгоритма "Полифонический - Сенсоры" Он позволяет регулировать порог, определяющий число одновременно звучащих нот.
Ползунок Фильтр гармоник появляется при выборе алгоритма "Одноголосье - Сенсоры". Он предотвращает распознавание обертонов вместо основных частот.
Ползунок Порог шума позволяет настроить фильтр шума, чтобы предотвратить распознавание нежелательных звуков как нот. Настраивайте его аккуратно, чтобы не потерять существенных нот.

Индикатор Уровня показывает уровень поступающего звука, который можно настроить с помощью системного микшера (см кнопку Микшер Windows). Рекомендуемое пиковое значение лежит в пределах -15...-5 Дб.

Вы можете подстраивать параметры распознавания не прерывая процесса распознавания; все изменения вступают в силу как только они производятся. Тем не менее, при включенной записи MIDI некоторые настройки становятся недоступны.

Для завершения распознавания и работы с распознанным MIDI нажмите Готово. Новый файл будет открыт в новом MIDI-окне.

Чтобы отменить распознавание нажмите Отменить.

.topic 10635
Диалог Опции устанавливает различные опции WIDI, не связанные непосредственно с процессом распознавания. Этот диалог вызывается нажатием кнопки   Основные Опции. Общие рекомендации по их настройке можно прочесть на странице Установка Опций.

Диалог Опции состоит из трех закладок:

Закладка Основные - устанавливает параметры интерфейса и автосохранения.

Закладка Обработка - управляет созданием GS- и временных файлов.

Закладка Устройства - устанавливает устройства ввода/вывода звука.

Кнопка OK подтверждает сделанные изменения, Отменить - отменяет их, Сбросить устанавливает параметры всех трех закладок в значения по умолчанию, Помощь вызывает контекстную справку.

.topic 10640
Диалог Параметры распознавания устанавливает различные параметры алгоритмов распознавания WIDI.
Диалог Параметры распознавания вызывается кнопкой   Настройки где вы можете установить параметры распознавания. На странице Настройка параметров распознавания имеются общие рекомендации по выбору алгоритмов и настройке параметров.

Диалог Параметры распознавания состоит из трех закладок:

Закладка "Звук->Тон" - устанавливает алгоритм для преобразования "Звук->Тон" и его параметры.

Закладка "Тон->MIDI" - устанавливает алгоритм для преобразования "Тон->MIDI" и его параметры.

Закладка Опции MIDI - устанавливает параметры для всех вновь создаваемых MIDI-файлов.

Кнопка OK подтверждает сделанные изменения, Отменить - отменяет их, Сбросить устанавливает параметры всех трех закладок в значения по умолчанию, Помощь вызывает контекстную справку.

Установки позволяют сохранять в файл с расширением .wset все параметры распознавания (включая установки Эквалайзера) и считывать их из этих файлов. Подробнее см. раздел установки.

.topic 10670
Задача Эквалайзера - дать возможность установить относительную громкость нот различных высот, или даже исключить из рассмотрения ноты определенных частот. Детальное описание можно найти в разделе Настройка Эквалайзера.
Чтобы вызвать окно Эквалайзера, выберите пункт меню Опции->Показать Эквалайзер или нажмите кнопку   Эквалайзер на панели инструментов. Также Вы можете использовать уменьшенное изображение Эквалайзера в правом нижнем углу основного окна WIDI. Нажатие на него вызывает окно Эквалайзера  .

В заголовке показывается выделенная нота, ее частота и относительная громкость.
Замечание: Октавы WIDI соответствуют стандартным октавам в MIDI плюс 3.

Флажок Поверх всех окон определяет, будет ли Эквалайзер находиться поверх остальных окон WIDI.

Кнопки 0%, 50% и 100% выставляют все регуляторы в соответствующее положение. Замечание: поскольку Эквалайзер управляет относительной громкостью, кнопки 50% и 100% приводят к одинаковому эффекту. Используйте эти позиции как промежуточные при настройке Эквалайзера.

Нажимая в область над клавиатурой Вы выставляете громкость соответствующей ноты. Двойной щелчок по ноте на клавиатуре приводит к установке ее в максимум либо минимум.

Чтобы прослушать отдельную ноту, нажмите на соответствующую клавишу клавиатуры, удерживая Shift.

Установки позволяют сохранять в файл с расширением .weqp установки Эквалайзера считывать их из таких файлов. Подробнее см раздел сохранение настроек.

.topic 30000
При запуске незарегистрированной версии WIDI сначала появляется следующий диалог:

Купить через Интернет открывает Страницу регистрации с помощью основного броузера.
Ввести код открывает Диалог регистрации, в котором Вы можете ввести регистрационную информацию.
ОК - запустить программу в тестовом режиме - в нем допускается сохранение не более 10 секунд MIDI.

Замечание: В соответствии с Лицензионным Соглашением Вы не можете пользоваться незарегистрированной программой дольше чем в течении 14-ти дней начиная с даты инсталляции.

.topic 20400
Диалог Свойства MIDI-файла устанавливает параметры текущего MIDI-фала. Этот диалог может быть вызван из Окна MIDI или Редактора TrueTone.

Эти параметры не влияют на процесс распознавания, тем не менее они определяют некоторые атрибуты создаваемого MIDI-файла.

Строка копирайта - эта строка записывается в MIDI-файл в качестве информации о копирайте.
Тональность - Вы можете назначить любую тональность для получаемой MIDI-композиции. Это не приводит к ее транспонированию.
Размер - Вы можете установить размер MIDI-композиции с помощью этого параметра ((2/4, 3/4, 3/8 и так далее).
Темп - устанавливает темп композиции.

.topic 10680
Окно Прогресс операции показывает текущее состояние операций, которые могут занять много времени.

Пауза приостанавливает обработку, возвращая системе ресурсы процессора.
Отменить прерывает операцию. Иногда реакция не мгновенна, особенно на медленных машинах.

.topic 30200
Диалог Регистрации используется для введения полученных после Регистрации WIDI регистрационного имени и кода. Он вызывается при помощи пункта меню "Помошь->Зарегистрировать!" либо из Стартового диалога.

Подробнее см. Введение регистрационного кода.

.topic 30500
Во многих диалогах программы имеется раздел "установки", позволяющий сохранять или восстанавливать текущие настройки.

Выпадающий список содержит названия установок, выбирая один из пунктов этого списка, пользователь устанавливает сразу все настройки диалога в соответствии с выбранной установкой.

Добавить предлагает ввести имя для сохранения текущих настроек.
Стереть стирает выбранную настройку из списка.

Настройки сохраняются в специальных файлах, находящихся в директории данных программы. При добавлении настройки файл с соответствующим названием появляется в этой директории, а при удалении – этот файл стирается.

Кнопка Экспорт сохраняет файл настроек в любую директорию, а кнопка Импорт позволяет прочитать файл настроек из любой директории.

Таким образом, файлы настроек могут быть перенесены с компьютера на компьютера или загружены из Интернет.

На нашем сайте вы можете найти пополняемую коллекцию настроек для распознавания по адресу http://www.widisoft.com/russian/presets.html.

.topic 20000
Основное окно редактора TrueTone состоит из нескольких областей. Расположение инструментов можно изменять, но по умолчанию редактор выглядит так, как показано на рисунке:

Область редактирования – это основная часть редактора, на которой отображаются ноты, наложенные на спектрограмму исходного произведения, предназначенная для визуального редактирования нот. См. Область редактирования.
Карта нот отображает все произведение целиком, и позволяет отобразить в области редактирования любую его часть. См. Карта нот.
Редактор треков – инструмент, позволяющий редактировать MIDI-данные по трекам. Он также может быть полезен для разделения MIDI-файла на голоса. См. Редактор треков.
Строка состояния – отображает параметры той ноты, над которой в данный момент находится курсор мыши, если же нет - то отображаются параметры выделенной ноты, так же как в диалоге Параметры ноты. Кроме того, справа показывается количество выделенных в данный момент нот.
Линейка – отображает шкалу времени или номера тактов. См. Линейка времени.

Панели инструментов состоит из нескольких отдельных панелей, соответствующих основным функциям редактора:
    Инструменты – дает возможность выбрать инструмент для визуального редактирования.
    Правка – содержит кнопки для работы с буфером нот и отмены операций.
    Выделение – управляет режимами и способами выделения нот.
    Проигрывание – позволяет проигрывать MIDI и исходный файл в различных режимах.
    Вид – управляет масштабом отображения спектрограммы и нот в области редактирования.
    Дополнительные – содержит кнопки для вызова дополнительных функций.

Пользователь может настроить интерфейс нотного редактора в соответствии со своими вкусами,  в том числе изменить расположение панелей инструментов и органов управления. Кроме этого,  пользователь может изменять количество кнопок и состав групп на панелях инструментов при помощи контекстного меню или пункта меню "Опции->Настройка панели инструментов редактора….".

.topic 20500
Редактор треков состоит из строк, каждая из которых соответствует  одному треку.

  - Номер трека указан слева, в самом начале каждой строки.

  - Кнопка, позволяющая выбрать цвет, котором будут отображаться все ноты данного трека.

  - имя трека. Можно изменить по нажатию левой кнопки мыши.

  - заглушить ноты данного трека.

  - спрятать ноты данного трека.

  - выделить  ноты данного трека.

Контекстное меню

Выделить трек выделяет ноты данного трека.
Заглушить трек заглушает ноты данного трека.
Спрятать трек прячет ноты данного трека.

Стереть трек стирает все ноты данного трека.
Новый трек создает пустой трек.

Спрятать пустые треки прячет все строки редактора треков, которым соответствуют треки, не содержащие  нот.

.topic 20510
Карта нот – это инструмент, позволяющий видеть уменьшенное изображение всего произведения в целом – так же как оно отображается в области редактирования. На карте красным прямоугольником отображается область, видимая в данный момент в основном окне. Прямоугольник можно двигать с помощью мыши.

Карта нот выполнена в виде перемещаемого инструмента, она может быть прикреплена к верхней или нижней границе окна, либо оставлена в виде плавающего окна – в этом режиме карта становится полупрозрачной, что бы не загораживать спектрограмму в области редактирования.

.topic 20600

  Редактировать включает инструмент "Редактирование". Этот инструмент позволяет визуально изменять длительность, положение и высоту ноты, а также использовать множественную селекцию.

При выбранном инструменте "Редактирование", для изменения длины ноты достаточно навести курсор на край ноты, после чего курсор изменится на горизонтальную стрелку, и, нажав левую клавишу мыши, двигать мышь горизонтально. При наведении курсора на середину ноты, нажатие на левую клавишу мыши приводит к захвату ноты, что позволяет передвигать ее, меняя как ее высоту так и время начала. Точно таким же образом можно перемещать и выделенную группу нот.

  Стирать ноты включает инструмент "Стирать", который предназначен для стирания нот. Все ноты, над которыми проводится курсор с нажатой левой кнопкой мыши, удаляются.

  Создавать ноты включает инструмент "Создавать новые ноты". При нажатии левой кнопки мыши над областью редактирования создается новая ноты. Аттрибуты создаваемой ноты можно изменить с помощью диалога Параметры нот по умолчанию.

  Склеивать ноты включает опцию "склеивать". В этом режиме, если одна нота наложилась при редактировании на другую, то они склеиваются в одну ноту. Результирующей ноте приписывается громкость наиболее громкой из двух, прочие параметры берутся у той ноты, которую двигали.

.topic 20610

  Вырезать вырезает выделенные ноты.
  Копировать копирует выделенные ноты.
  Вставить вставляет содержимое буфера в начало отображаемой в окне редактирования области.

  Отменить пошагово отменяет предыдущие операции.
  Повторить пошагово повторяет отмененные операции.

.topic 20620

  Выделить вызывает диалог Фильтр нот.
  Первая выделенная нота в окне редактирования область, в которой находится первая выделенная нота.
  Последняя выделенная нота показывает в окне редактирования область, в которой находится последняя выделенная нота.
  Режим добавления к выделенному изменяет режим селекции. Если кнопка не нажата, то выделение следующей ноты снимает выделение с предыдущей.  Если же она нажата – новые ноты будут добавляться к уже выделенным. Аналогичное действие имеет клавиша Shift.

.topic 20630

  Проиграть экран запускает проигрывание всех видимых в основной области редактирования нот (при этом ноты сверху и снизу видимой области также играются).
  Проиграть выделенное запускает проигрывание всех выделенных нот.
  Проиграть все включает проигрывание всего произведения целиком.
  Стоп останавливает проигрывание.

  Режим проигрывания - позволяет выбрать один из следующих режимов проигрывания:
       MIDI включает режим проигрывания "только MIDI".
       Аудио включает режим проигрывания "только аудио".
       Аудио + MIDI включает режим синхронного проигрывания MIDI и аудио.
       MIDI замедленно включает режим замедленного проигрывания MIDI. Степень замедления проигрывания можно 	выставить в настройках редактора, по умолчанию, проигрывание происходит на половинной скорости.

  Проигрывать в цикле включает режим циклического воспроизведения.

.topic 20640

  Увеличить увеличивает в два раза масштаб изображения в области редактирования.
  Уменьшить уменьшает масштаб изображения в два раза.
  Масштаб по умолчанию устанавливает масштаб в значение по умолчанию.

  Показывать тактовые черты включает режим показа тактовых черт.

.topic 20650

  Параметры ноты вызывает диалог Параметры ноты.
  Параметры ноты по умолчанию вызывает диалог Параметры ноты по умолчанию.

  Открыть соответствующую аудио-запись открывает связанный аудио-файл.

  Создать файл MIDI создает отдельное окно с текущими MIDI-даными редактора.

  Теппинг вызывает инструмент Теппинг.

.topic 20700
Диалог Опции редактора TrueTone управляет различными особенностями поведения редактора TrueTone. Этот диалог вызывается с помощью пункта меню "Опции->Опции редактора TrueTone".

Диалог Опции редактора TrueTone состоит из трех закладок:

  Закладка Основные - устанавливает параметры интерфейса и селекции.

  Закладка Проигрывание - управляет настройками проигрывания.

  Закладка Фокусировка - управляет особенностями фокусировки.

Кнопка OK подтверждает сделанные изменения, Отменить - отменяет их, Сбросить устанавливает параметры всех трех закладок в значения по умолчанию, Помощь вызывает контекстную справку.

.topic 20710

 Показывать
Крупные иконки регулирует размер иконок на кнопках панели инструментов.
Показать Карту Нот управляет появлением инструмента "карта нот".
Показывать тактовые черты включает отображение тактовых черт.
Отображать тактовые черты на линейке переключает отображение на верхней линейке на номера тактов. По умолчанию на ней отображается время.

 Редактор треков
Показывать Редактор Треков управляет тем, будет ли по умолчанию показан редактор треков.
Спрятать пустые треки прячет строки редактора треков, соответствующие трекам без нот.

 Выделение
Данный переключатель влияет на режим селекции – положение Добавить к выделенным приводит к тому что при выделении новых нот выделение со старых не снимается (аналогично действует клавиша Shift). Если же выбран пункт Заменить выделение то выделение новой ноты будет сопровождаться снятием выделения с предыдущей.

.topic 20720

Скорость замедленного проигрывания управляет тем, насколько (в процентах) будет замедленно проигрывание MIDI в режиме замедленного проигрывания.
Циклическое воспроизведение устанавливает режим закольцованного проигрывания.

.topic 20730

 Отмена и Повтор
Фокусировать управляет тем, будет ли область редактирования показывать то место где при совершении этих операций произошли изменения.
Сфокусировать до операции заставляет редактор совершать операции в два шага. Сначала показывается область, с которой будут происходить изменения, а собственно операция выполняется при повторном нажатии на кнопку.

 Где фокусироваться
Этот переключатель дает возможность управлять фокусировкой в том случае если выделенный фрагмент оказывается больше размера области отображения. положение Начало выделения заставляет редактор фокусироваться на первой ноте выделенной группы, а Середина выделения – на середине группы.

 Различные настройки
Фокусироваться при Вырезании заставляет редактор переместить фокус в ту точку где производится вырезание.
Фокусироваться при множественном выделении управляет тем, будет ли редактор фокусироваться на выделенной группе нот.

Замечание: Фокусировка при выделении не происходит, если хотя бы одна из выделяемых нот и так видна в области редактирования.

.topic 20800
Диалог Фильтр нот позволяет выделять ноты, удовлетворяющие определенным критериям. Параметр выбирается установкой соответствующего флага. Можно указывать один или более параметров выбора.

Фильтр нот вызывается нажатием кнопки   Выделить на панели инструментов Выделение либо с помощью пункта меню "Выделение->Выделение...".

 Критерии

Левый столбец флагов заставляет учитывать при проверке следующие параметры:
Время устанавливает временной диапазон звучания нот.
Высота устанавливает диапазон по высоте тона.
Канал устанавливает MIDI каналы.
Громк. устанавливает громкость нот.
Длит. устанавливает длительность нот.
Трек устанавливает номер MIDI трека.
Инстр. устанавливает музыкальный инструмент.

Для всех параметров, кроме инструмента, справа указывается диапазон значений, удовлетворяющих заданному условию: в поле от указывается нижняя граница диапазона, в поле до - верхняя.
Флажок не позволяет инвертировать это условие – то есть такому условию будут удовлетворять все ноты кроме нот с параметром, находящимся в выбранном диапазоне.

 Действие

Выделить позволяет выделить ноты удовлетворяющие условию, при этом предыдущее выделение сбрасывается.
Добавить добавляет к уже выделенным нотам те ноты, которые удовлетворяют условию.
Сузить дает возможность среди всех уже выделенных нот оставить только те, которые удовлетворяют заданным критериям.

Фокусироваться на выделенных нотах автоматически устанавливает видимую область на начало или конец селекции – в зависимости от установок диалога Опции редактора TrueTone.

Поле Установки позволяет сохранить установки фильтра для повторного использования.  Файл установок диалога Фильтр нот имеет расширение .wnef.  Подробнее об использовании файлов установок можно прочитать в разделе сохранение настроек.

Кнопка OK выделяет ноты в соответствии с установленными правилами, Отменить - закрывает диалог, Сбросить устанавливает все параметры в значения по умолчанию, Помощь вызывает контекстную справку.

.topic 20810
Диалог Теппинг позволяет осуществлять расстановку тактовых черт на слух.
Диалог Теппинг вызывается нажатием кнопки   Теппинг на панели инструментов Дополнительные либо с помощью пункта меню "Инструменты->Теппинг".

 Проигрывать
Аудио - при выборе этого пункта во время расстановки тактовых черт проигрывается исходный аудио-файл.
MIDI  - при выборе этого пункта проигрывается результат распознавания.

Старт запускает проигрывание.
Стоп останавливает проигрывание.

Расстановка тактовых черт осуществляется с помощью пробела, либо соответствующей кнопкой Поставить черту в центре диалога. Проигрывание можно также запустить клавишей пробел.

Показывать текущую позицию включает указатель позиции проигрывания. Не используйте эту установку на медленных компьютерах.

Подробнее о расстановке тактовых черт можно прочитать в разделе тактовые черты.

.topic 20300
Диалог Настройка цвета используется для настройки цветов рабочего пространства редактора TrueTone. Набор цветов отличается для обычного режима и режима "только MIDI".

Лежащий в основании окна спектр составляется из градиентов следующих трех цветов:
Фон - цвет подложки спектра или нулевого уровня.
Средняя точка спектра - цвет участков средней интенсивности.
Максимальная точка спектра - цвет участков наибольшей интенсивности.
Ноты - цвет прямоугольников, соответствующих нотам.
Выделенные ноты - цвет прямоугольников, соответствующих выделенным нотам.
Рамка выделения - цвет прямоугольника выделения.
Выделение - цвет заливки прямоугольника выделения.
Позиция проигрывания - цвет линии, показывающей место, проигрываемое в настоящий момент.
Тактовые черты - цвет которым отображаются тактовые черты.

В режиме "только MIDI" некоторые пункты отсутствуют, другие добавляются:
Заливка нот - цвет, заполняющий прямоугольники нот.
Заливка заглушенных нот - цвет, заполняющий заглушенные ноты.

Цветной квадрат справа показывает текущий цвет соответствующий выделенному пункту. Нажатие на цвет позволяет выбрать цвет из списка. Выберите пункт "Custom..." для вызова расширенного диалога выбора цвета.

Контраст - регулирует относительную яркость интенсивных и слабых участков спектра. При слишком высоком контрасте видны только самые громкие ноты, при слишком низком на экране появляется много несущественных деталей.

Раздел Установки позволяет сохранять цветовые схемы и экспортировать их в файл специального формата с расширением .wnec.  Подробнее об использовании файлов установок можно прочитать в разделе сохранение установок.

.topic 20200
Диалог параметры ноты устанавливает свойства конкретной ноты.

Время показывает абсолютное время начала ноты относительно начала композиции в секундах.
Нота отображает высоту ноты. WIDI работает в энгармонической шкале, используя соответствующие диезы вместо бемолей (например "C#" вместо "Db"). Замечание: Октавы WIDI соответствуют стандартным октавам в MIDI плюс 3.
Громк соответствует громкости соответствующей ноты в единицах MIDI.
Канал соответствует MIDI каналу который будет использован для проигрывания ноты. Только один инструмент может быть звучать на одном канале в одно и то же время, ноты одновременно играемые разными инструментами могут привести к нежелательному результату. 10-й канал как-правило отводится для ударных. Вообще не рекомендуется использовать более чем 16 каналов.
Длит, с - длительность ноты в секундах.
Трек - номер трека. Треки используются для группировки частей композиции без изменения их звучания.
Инструмент - инструмент используемый для проигрывания ноты.

.topic 20100
Диалог параметры нот по умолчанию определяет параметры по умолчанию, присваиваемые любой вновь создаваемой в редакторе TrueTone ноте.

Громк соответствует громкости ноты в единицах MIDI.
Канал соответствует MIDI-каналу который будет использован для проигрывания ноты. Только один инструмент может быть звучать на одном канале в одно и то же время, ноты одновременно играемые разными инструментами могут привести к нежелательному результату. 10-й канал как-правило отводится для ударных. Вообще не рекомендуется использовать более чем 16 каналов.
Длит, с - длительность ноты в секундах.
Трек - номер трека. Треки используются для группировки частей композиции без изменения их звучания.
Инструмент - инструмент используемый для проигрывания ноты.

.topic 20820
Диалог Изменить длину пьесы устанавливает длину пьесы.

Этот диалог может быть вызван с помощью пункта меню "Операции"->"Установить длину произведения...".

Длина содержит новое значение для длительности пьесы.

Замечание: При уменьшении длины пьесы часть нот может быть необратимо потеряна.

.topic 30100
Лицензионное Соглашение

ПЕРЕД ИСПОЛЬЗОВАНИЕМ ПРОГРАММЫ ВНИМАТЕЛЬНО ПРОЧТИТЕ ВСЕ УСЛОВИЯ
ДАННОГО СОГЛАШЕНИЯ. ИСПОЛЬЗОВАНИЕ ПРОГРАММЫ ОЗНАЧАЕТ ВАШЕ СОГЛАСИЕ
С УСЛОВИЯМИ ДАННОГО СОГЛАШЕНИЯ. ЕСЛИ ВЫ НЕ СОГЛАСНЫ С УСЛОВИЯМИ
СОГЛАШЕНИЯ, НЕ ИСПОЛЬЗУЙТЕ ПРОГРАММУ.

Все имущественные права на программу WIDI Recognition System (в дальнейшем
именуемую "Программа") принадлежат компании WIDISOFT (в дальнейшем
- WIDISOFT). WIDISOFT разрешает использование Программы при
условии Вашего согласия со следующими положениями.

Вы можете свободно распространять незарегистрированную тестовую
версию Программы, соблюдая целостность и неизменность
дистрибутива. Вы не имеете права предпринимать обратное
конструирование, декомпиляцию или дизассемблирование Программы или
использовать любой другой метод для преобразования в форму,
воспринимаемую человеком а также разрешать кому-либо делать это.

Предполагается, что Вы полностью оцените работу и функциональность
Программы за 14-дневный тестовый период до совершения покупки.
Данный принцип "попробуй перед покупкой" обеспечивает надлежащую
проверку на соответствие Вашим требованием. Поэтому Вы
соглашаетесь с тем, что возврат денег после совершения покупки не
предусмотрен.

Если Вы являетесь зарегистрированным пользователем, Вы можете
использовать программу для собственных нужд. Запрещается
давать в прокат или во временное пользование как Программу так и
Вашу персональную регистрационную информацию  кому-либо без письменного
разрешения WIDISOFT. Вы можете  одновременно использовать только одну
копию Программы. Запрещается использование программы в сетях или более
чем на одной машине без соответствующей лицензии. Вы имеете право
полностью уступить право пользования Программой другому лицу, при этом
вы теряете  право пользования Программой.

Лицензия и право использования Программы не включает  право на  использование,
кодирование или любое другое изменение обрабатываемых Программой данных для
продажи, публикации, а также распространения на любых носителях, в
сетях общего пользования и широковещательных сетях.

РАСПРОСТРАНЯЕТСЯ НА УСЛОВИЯХ "КАК ЕСТЬ". WIDISOFT НЕ БЕРЕТ НА СЕБЯ
И НЕ ПОДРАЗУМЕВАЕТ КАКИХ-ЛИБО ГАРАНТИЙНЫХ ОБЯЗАТЕЛЬСТВ. WIDISOFT
НЕ ОБЯЗУЕТСЯ ОБЕСПЕЧИВАТЬ ОБНОВЛЕНИЯ И ТЕХНИЧЕСКУЮ ПОДДЕРЖКУ
ПРОГРАММЫ. ВЫ ИСПОЛЬЗУЕТЕ ПРОГРАММУ НА СВОЙ РИСК. WIDISOFT НЕ
БЕРЕТ НА СЕБЯ ОТВЕТСТВЕННОСТЬ ЗА ПОТЕРЮ ДАННЫХ, УЩЕРБ, ПОТЕРЮ
ПРИБЫЛИ ИЛИ ЛЮБЫЕ ДРУГИЕ ПОТЕРИ, ПРОИЗОШЕДШИЕ ВО ВРЕМЯ
ИСПОЛЬЗОВАНИЯ ИЛИ НЕПРАВИЛЬНОГО ИСПОЛЬЗОВАНИЯ ДАННОГО ПРОГРАММНОГО
ОБЕСПЕЧЕНИЯ.